Forum Replies Created

  • gcrews

    Reply To: 100% cpu on on output dalog

    Participants 0
    Replies 198
    Last Activity 10 years, 10 months ago

    Ok, now it’s not doing it. I completely uninstalled Xmetal 6.0, rebooted, and then reinstalled again as I did about a week ago when the dialog box was going nuts. No CMS involved. I’m not sure what changed, I will let you know if it comes back. I can’t think of anything that I had tweaked or changed in Xmetal since the last reinstall that would have caused the issue.

    Reply

    gcrews

    Reply To: 100% cpu on on output dalog

    Participants 0
    Replies 198
    Last Activity 10 years, 10 months ago

    @class values should be being added

    should  or should not?

    Reply

    gcrews

    Reply To: 100% cpu on on output dalog

    Participants 0
    Replies 198
    Last Activity 10 years, 10 months ago

    Ok the problems kind of back, but not on the output dialog.  I’ve been trying to work with a few DITA maps the past couple of days. The maps are kind of big with about 1000 topic refs to html files. I used to be able to edit and work with them fine. Now for some reason Xmetal bogs down on them like no buddies business. The take 20 seconds to open. When I try and save it pretty much locks up going at full CPU.  Sometimes just clicking somewhere in the document makes Xmetal go berserk.  Any Ideas? I even tried turning off while you type spell checking but that did not help anything.

    Update: After about 5 min of going 100% Xmetal finally saved the document. I think I figured out what is gobbling up so much CPU while saving.  Comparing the text of the saved file to another copy, Xmetal added class=”- map/topicref ” and all the extra class junk to the ditamap. It’s doing that on topic files and stuff to now when I save. Is there some option that I somehow checked in Xmetal that no turned on that is now adding all that stuff to all the documents I save and taking a lot more CPU usage?  I looked at some of the attached dlls to Xmetal and saw that it looks like that .NET update updated a few dlls Xmetal uses. The System.xml one seems a bit interesting. I think that controls some of the xml serialization and stuff.

    Reply

    gcrews

    Reply To: Microsoft Error, crash with XMetaL 6.0

    Participants 0
    Replies 198
    Last Activity 10 years, 10 months ago

    It’s probably best to reinstall Xmetal completely. Alternatively you can re run the exe before uninstalling Xmetal and it will probably give the option to repair. Additionally when you run the setup exe you actually extract the files and MSI. Check the section “Silent installer” in the readme (http://www.xmetal.com/_trials/install-readme.html)

    Reply

    gcrews

    Reply To: Microsoft Error, crash with XMetaL 6.0

    Participants 0
    Replies 198
    Last Activity 10 years, 10 months ago
    gcrews

    Reply To: Xmetal default output folder

    Participants 0
    Replies 198
    Last Activity 10 years, 10 months ago

    I would like to separate it out for both reasons and a few others.
       Adds a bunch of extra files that have to get searched thorough when using windows search.
       When you generate to the same output folder no one can have the file open.
       If your editing the output css it can sometimes override the toolkit css and not get replaced.
       If there are any compile errors in individual files you end up with old data in the final output.
             I have run into this many times where I am modifying the toolkit any it uses old output files.
       More and more writers are generating output for files and maps throught the day.

    From experience it would just seem better to generate output to individual users computer. The only way I see to do that in XMetaL is to define the output to a single location. The problem with that is that every output you run will be going to the same chm_out folder or what not. Generating output to a folder that potently has files already in it just seems like a bad idea.  I actually tried once to add a clean output directory stage to the toolkit but XMetaL locks on to a file in the output directory as soon as the compile starts. I'm also weary about having it clean out the output directory  since someone could possibly specify an output folder that has non output content in it. Example would be a user just browsing to their desktop and generating output.

    PS:about the “extra” files there are about 30 or so hm*.xml or something files that have appeared up over time. I assume they are temp files XMetaL has forgotten about that can be removed.

    Reply

    gcrews

    Reply To: Copy and paste error in eval version 6.0.1.030

    Participants 0
    Replies 198
    Last Activity 10 years, 11 months ago

    Good to know there a newer version, how are users supposed to find out when new releases are out? It would be nice to be able to stay on the current release so we don’t run into issues that may have already been solved. Or is it preferred to just update when there are major releases?

    Reply

    gcrews

    Reply To: Copy and paste error in eval version 6.0.1.030

    Participants 0
    Replies 198
    Last Activity 10 years, 12 months ago

    1. Windows Ultimate 7, 64-bit (XMetaL running in compatibility mode for Windows XP – Service Pack 3).

    If i remember correctly compatibility mode in win 7 is just a vm system. That could potentially be the issue to with copy and pasting between the virtual PC.
    Also, is this XMetaL author enterprise? The current link takes you to a download of 6.0.47 but installs 6.0.0.122 (unless the file has been updated since i last looked but the file name stayed the same) wonder where 6.0.1.030 is coming from. I vaguely remember the 030 from earlier XMetaL 6 release but youed think the version number would increase and not decrease in the second segment number.

    Reply

    gcrews

    Reply To: Copy and paste error in eval version 6.0.1.030

    Participants 0
    Replies 198
    Last Activity 10 years, 12 months ago

    Just a thought, Is the word file on a network drive or on a Sharepoint server? Perhaps having it saved locally would change the behavior.

    Reply

    gcrews

    Reply To: Upgrade to 6.0 — map editor crash?

    Participants 0
    Replies 198
    Last Activity 11 years ago

    I'm glad you were able to reproduce the issue on your side.
    Thanks for all the help trying to debug this issue.

    Additional information:
    We have  4 other writers extensively using XMetaL 5.5 during the day with the same McAfee version, settings, and policies with no issues. There must have been something changed in XMetaL 6 that  introduced this issue.

    The host system I ran my VM test on was an Intel q6600 with VT-x,  witch may attributive to it crashing on  my test vm and not on your side.

    Here is the last stack trace after a crash: ( you can probably get this info now)
    Faulting application xmetal60.exe, version 6.0.0.122
    faulting module oleaut32.dll, version 5.1.2600.5512
    fault address 0x00004942.
    [email protected]()  + 0x52 bytes
    jscript.dll!VAR::Clear()  + 0x47 bytes
    jscript.dll!GcAlloc::ReclaimGarbage()  + 0x77 bytes
    jscript.dll!GcContext::Reclaim()  + 0x17e bytes
    jscript.dll!GcContext::Collect()  – 0x225 bytes
    jscript.dll!CScriptRuntime::Run()  – 0x6368 bytes
    jscript.dll!ScrFncObj::Call()  + 0x85 bytes
    jscript.dll!NameTbl::InvokeInternal()  + 0x5a95 bytes
    jscript.dll!VAR::InvokeByDispID()  + 0x1f7d bytes
    jscript.dll!CScriptRuntime::Run()  + 0x5592 bytes
    jscript.dll!ScrFncObj::Call()  + 0x85 bytes
    jscript.dll!NameTbl::InvokeInternal()  + 0x6b bytes
    jscript.dll!VAR::InvokeByDispID()  + 0x1f7d bytes
    jscript.dll!VAR::InvokeByName()  + 0x6566 bytes
    jscript.dll!VAR::InvokeDispName()  + 0x40 bytes
    jscript.dll!VAR::InvokeByDispID()  + 0x54 bytes
    jscript.dll!CScriptRuntime::Run()  – 0x1c65 bytes
    jscript.dll!ScrFncObj::Call()  + 0x85 bytes
    jscript.dll!NameTbl::InvokeInternal()  + 0x6b bytes
    jscript.dll!VAR::InvokeByDispID()  + 0x1f7d bytes
    jscript.dll!VAR::InvokeByName()  + 0x6566 bytes
    jscript.dll!VAR::InvokeDispName()  + 0x40 bytes
    jscript.dll!VAR::InvokeByDispID()  + 0x54 bytes
    jscript.dll!CScriptRuntime::Run()  – 0x1c65 bytes
    jscript.dll!ScrFncObj::Call()  + 0x85 bytes
    jscript.dll!NameTbl::InvokeInternal()  + 0x6b bytes
    jscript.dll!VAR::InvokeByDispID()  + 0x1f7d bytes
    jscript.dll!VAR::InvokeByName()  + 0x6566 bytes
    jscript.dll!VAR::InvokeDispName()  + 0x40 bytes
    jscript.dll!VAR::InvokeByDispID()  + 0x54 bytes
    jscript.dll!CScriptRuntime::Run()  + 0x5592 bytes
    jscript.dll!ScrFncObj::Call()  + 0x85 bytes
    jscript.dll!CSession::Execute()  – 0x398 bytes
    jscript.dll!COleScript::ExecutePendingScripts()  + 0x141 bytes
    jscript.dll!COleScript::ParseScriptTextCore()  + 0x1a6 bytes
    jscript.dll!COleScript::ParseScriptText()  + 0x2b bytes
    xmetal60.exe!00a16f32()
    [Frames below may be incorrect and/or missing, no symbols loaded for xmetal60.exe]

    Here is a hack I came up with: (reset the WHS reg keys, open XMetaL, set WHS keys back)
    As long as you don't open Iexplorere or Outlook during the time the keys are changed and you don't surf the web in in the preview pane after clinking a link in a document I don't think there is much of a security risk.

    REGEDIT.EXE /S “%~dp0reg.reg”
    rem reg.reg
    rem Windows Registry Editor Version 5.00
    rem [HKEY_CLASSES_ROOTCLSID{f414c260-6ac0-11cf-b6d1-00aa00bbbb58}InprocServer32]
    rem @=”C:\WINDOWS\system32\JScript.dll”
    rem [HKEY_CLASSES_ROOTCLSID{B54F3741-5B07-11cf-A4B0-00AA004A55E8}InprocServer32]
    rem @=”C:\WINDOWS\system32\VBScript.dll”

    start “XMetaL” /B “C:Program FilesXMetaL 6.0Authorxmetal60.exe”
    PING 1.1.1.1 -n 1 -w 20000
    REGEDIT.EXE /S “%~dp0mc.reg”
    rem mc.reg
    rem Windows Registry Editor Version 5.00
    rem [HKEY_CLASSES_ROOTCLSID{B54F3741-5B07-11cf-A4B0-00AA004A55E8}InprocServer32]
    rem @=”C:\Program Files\McAfee\VirusScan Enterprise\scriptsn.dll”
    rem [HKEY_CLASSES_ROOTCLSID{f414c260-6ac0-11cf-b6d1-00aa00bbbb58}InprocServer32]
    rem @=”C:\Program Files\McAfee\VirusScan Enterprise\scriptsn.dll”

    Reply

    gcrews

    Reply To: Upgrade to 6.0 — map editor crash?

    Participants 0
    Replies 198
    Last Activity 11 years ago

    I did some testing and even with one core CPU system it still crashes. There does seem to be a fair amount of issues with McAfee and ScriptScan. I think the issues may just be more prominent in XMetaL because of its extensive JavaScript usage and calls. When I do stack traces of the debug the last call is almost always to OLEAUT32!VariantClear(… In the jscript.dll Garbage collection stuff. To me that’s seems more like an issue with the way the ScriptScan proxies the stuff and not per say any coding in XMetaL. We will see what MacAfee can figure out.

    Reply

    gcrews

    Reply To: Upgrade to 6.0 — map editor crash?

    Participants 0
    Replies 198
    Last Activity 11 years ago

    Interesting Microsoft kb I found that give a little more insight into what the ScriptScan is doing:
    http://support.microsoft.com/kb/890736

    “This problem is typically caused by McAfee VirusScan Enterprise 8.0i. Specifically, the problem may occur when the McAfee Scriptscan.dll component scans a script that calls an ActiveX control.

    The McAfee ScriptScan component replaces the Windows Script Host component with its own proxy component. The McAfee ScriptScan proxy component (ScriptProxy.dll) scans JavaScript and Visual Basic Scripting Edition (VBScript) scripts. When a script is executed and passes through the scan as clean, the script is passed on to the appropriate Windows Script Host.

    However, the ScriptProxy.dll component may cause an access violation when it parses the Active Directory Management Pack scripts in the MOMHost.exe process that calls ActiveX controls. When the ScriptProxy.dll component stops responding, the MOMHost.exe process that is running the script also fails. The MOM service tries to restart the failed MOMHost.exe process, and the access violation is repeated.”

    Reply

    gcrews

    Reply To: Upgrade to 6.0 — map editor crash?

    Participants 0
    Replies 198
    Last Activity 11 years ago

    Is the “processes on enable” on the first option tab checked or not? I know that when I was doing some testing on a clean system there didn’t seem to be any issues when that was unchecked as it is by default Xmetal does not seem to crash but found that if it is checked then Xmetal starts to crash.  I tried un-checking it on my main computer that I work on though and Xmetal still crashed when that was unchecked. I wonder if it has something to with the performance when more stuff is running.  It seems to be some kind of issue with timing collision issue.

    Reply

    gcrews

    Reply To: Trouble Opening files across the network XMAE 6

    Participants 0
    Replies 198
    Last Activity 11 years ago

    Sounds kinda like the os is waiting on something. Does the open dialog in other apps like office do the same thing?  If so it may be some other mapped drive or drive step on that system.  This sounds like the same issue http://www.hargopal.com/84/very-slow-file-open-save-dialog-boxes-in-ms-office/

    Reply

    gcrews

    Reply To: Possible to use conditions for different chapters of same book?

    Participants 0
    Replies 198
    Last Activity 11 years ago

    Sounds like the same issue I had about a month ago when I needed to conditionally process different things in same deliverable. I asked on the dita-users forum and got a bunch of good feedback.
    http://tech.groups.yahoo.com/group/dita-users/message/18259

    What I ended up doing was to create a build run that first compiles a map though a new target I created that filters the content with a datival. The filtered xml files get placed in a folder where I can then run my final compile on and it will pull in the conditionally processed files into the final. It’s a bit of a kluge but it works for us for the current time being. It seems like dita 1.2 may have some ways to get this done.

    Here is the target I made that just filters the files and copies any referenced images:


     
     

    Reply

Products
Downloads
Support