General XMetaL Discussion

XMetaL Community Forum General XMetaL Discussion Xmetal is not rendering images

  • yesasvi

    Xmetal is not rendering images

    Participants 5
    Replies 6
    Last Activity 6 years, 6 months ago

    my application renders xml and we use  xmetal author 4.6 to view that xml ,previously images were getting rendered without any problem now the images are not getting rendered. From the app side we dint do any changes
    any help on this would be appreciated

    Reply

    Derek Read

    Reply to: Xmetal is not rendering images

    Check the following:

    1. Are the paths in the references to your images correct?
     Have you moved any images, or any XML files, or renamed any folders or made changes to any catalog files?
     If a CMS is being used have any settings been changed on the server?

    2. Does the CTM file associated with your schema (DTD or XSD) include the proper settings that tell XMetaL Author to render a particular element as an image? You may have modified the CTM file directly, it may have been deleted, overwritten, moved, or become corrupted, or if this is a new installation perhaps you did not know the CTM file does this and to include it (if someone else originally created the customization for this schema).

    3. Have you started referencing images of a new file type that might not be supported in this old release (or any release)? If so, you might need to do some additional work to support them (see #4 below).

    4. If the file type being referenced as an image is not supported natively (native support includes BMP, GIF, PNG, JPG, WMF, EMF, TIF, PCX, TGA, ICO) then some files in addition to the CTM settings can be required. In newer releases this is configurable, but with this old release script code must be written. This would include at minimum an MCR file with “OnInitialize” and possibly “OnShouldCreate” macros and if there is no default capability built into your version of Windows you may also need to install additional software or an ActiveX control to do the actual rendering. For 4.6 that would include the following file types and an associated ActiveX control capable of rendering them (these are known to be configured by our clients): SVG, CGM, HTML, MS Excel, PDF, and various video file types. Similar to #2, these files might be missing, corrupt, etc.

    5. Version 4.6 is from 2005/6 and was tested on Windows 2000 and XP only. Perhaps you have upgraded Windows and run into one of many issues we identified and corrected to make our software compatible with the significant changes Microsoft introduced with Windows Vista and Windows 7 and more minor issues introduced with Windows 8, 8.1 and 10. That work was started with version 5.5 and mostly completed by version 6.0 SP1 (for Vista / 7). Many other improvements have been made since then. The current release is XMetaL Author Enterprise 11 and is the first release to support Windows 10.

    Reply

    yesasvi

    Reply to: Xmetal is not rendering images

    Hi Derek,

    Yes the references correct,No changes were made to the catalog file .XML rendered is not able to render images in normal view but in page/browser preview it is able to render images.
    NO CMS file is not used .

    CTM file has image attribute.

    Is there any way to validate the files i have are not corrupted .

    any help would be really appreciated

    Thanks and Regards
    Yesasvi

    Reply

    Derek Read

    Reply to: Xmetal is not rendering images

    You can check the CTM file by loading it into XMetaL Developer's CTM editor.

    Or you could submit a support case to XMetaL Support and provide them with your complete customization and a sample XML file to test. They wouldn't be able to test version 4.6 (Windows XP and 2000 aren't supported by Microsoft any longer, so our old software that runs on those versions of Windows aren't supported any longer either) but they could load your customization into a more recent version. The CTM file format has changed a bit over the years but old files are compatible with newer releases.

    Reply

    yesasvi

    Reply to: Xmetal is not rendering images

    Thank you Derek 
    sounds silly but i am asking you, where can i find the tool you mentioned (XMetaL Developer's CTM editor)

    support case should be raised from which site can you please mention 

    thanks in advance

    Reply

    Derek Read

    Reply to: Xmetal is not rendering images

    If you do not already have XMetaL Developer you will need to check with our sales team to obtain a copy.

    The current version is XMetaL Developer 9 (and version 11 is being released this year). They would not be able to provide you with XMetaL Developer 4 as that old version is not supported.

    Reply

    yesasvi

    Reply to: Xmetal is not rendering images

    Thank you Derek

    Reply

  • You must be logged in to reply to this topic.

Lost Your Password?

Products
Downloads
Support