DITA and XMetaL Discussion

XMetaL Community Forum DITA and XMetaL Discussion XMetal is inserting spaces when <cite> element surrounds <ph> element

  • ScottG

    XMetal is inserting spaces when <cite> element surrounds <ph> element

    Participants 3
    Replies 4
    Last Activity 11 years, 1 month ago

    I am using XMetaL(R) Author Enterprise 5.5 with the SDL Trisoft plug-in on a Windows 7 machine.

    Here's my situation:
    1. I enter the following code in my XML file:
    Configuration Guide

    2. I  check in the XML file using the SDL Trisoft plugin.

    3. I check out the XML file. The code formatting has changed to:

      Configuration Guide
    .
    This initially doesn't seem like a problem, since it appears XMetaL is just trying to format the XML to make it more readable. However, XMetaL is also inserting an extra space on either side of the element. When I publish the document, there are extra spaces around 'Configuration Guide'.

    My initial feeling is that this is a bug in the way XMetaL is automatically formatting the XML. Anyone else run into this or know of a solution?

    Reply

    Derek Read

    Reply to: XMetal is inserting spaces when <cite> element surrounds <ph> element

    If it is not possible to alter your publishing system to deal with this white-space (that would be the ideal) it is possible to turn the pretty printing applied by XMetaL Author Enterprise for DITA documents off by running a macro (listed in the Macros toolbar) called “DITA Configuration: Turn OFF Pretty-Printing”.

    Disabling pretty printing will not “fix up” documents that have already been saved however. You will need to deal with such files individually, or perhaps via some batch process.

    If you need to have pretty printing turned on (so you can read the XML source more easily) but alter the behaviour for particular elements it is possible to configure the design of the pretty printing settings on a per-element basis. This is something our services team can help with if it is a requirement for you. The product includes a .ctm file for each DTD and it is file that controls various editing behaviours including pretty printing settings.

    Reply

    edwardwoodward

    Reply to: XMetal is inserting spaces when <cite> element surrounds <ph> element

    Hello

    Using XMetaL 8 SP1, Japanese.

    These extra spaces are causing a problem for us, so we want to turn off pretty printing, but when we click “Run” (not sure of the English button name), we get a pretty drastic warning message telling of potential dire consequences. Is this a standard message that also pops up in English versions, or is there something else we should worry about?

    Cheers.

    Reply

    Derek Read

    Reply to: XMetal is inserting spaces when <cite> element surrounds <ph> element

    The files that need to be changed are inside C:Program Files (where XMetaL Author Enterprise is installed) and on newer versions of Windows that location is restricted to being changed only by users with admin rights (similar to installing software). That is all the message is telling you. It is the same on the English edition.

    Reply

    edwardwoodward

    Reply to: XMetal is inserting spaces when <cite> element surrounds <ph> element

    Thanks for the confirmation.

    Reply

  • You must be logged in to reply to this topic.

Lost Your Password?

Products
Downloads
Support