General XMetaL Discussion

  • jmblachman

    XMetaL Author 8.0 lag

    Participants 2
    Replies 3
    Last Activity 9 years, 4 months ago

    Some of my clients are having slowness issues using XMetaL Author Enterprise Version#: 8.0.0.036. They are experiencing intermittent lagging when trying to edit xml files in both normal and plain text views. Additionally, one user is experiencing the frames around the XMetaL program disappearing temporarily. It doesn't seem to be a computer issue as the users have plenty of free CPU and memory (gigabytes of free memory).
    I've noticed on the threads that having McAfee VirusScan 8.x installed (which they do) may cause some issues, but all of the issues seem to be related to XMetaL Author 6, not 8.
    Oddly enough, one of the users claims that when they turn off the automatic spellchecker, the issue improves drastically.
    Any reason why this may be happening?

    Reply

    Derek Read

    Reply to: XMetaL Author 8.0 lag

    If turning off the “spell check as you type” feature speeds thing up that isn't something we are able to reproduce at the moment. In XMetaL Author Enterprise 8.0 that feature only checks a screenful at a time (what you currently see on the screen) so should be very fast. The spell check as you type functionality doesn't do anything in Plain Text view, so if turning it off seems to be helping there I can't imagine why. For Tags On or Normal view I suspect there must be something in the configuration, customization files, or the XML content to trigger this.

    You could try to confirm that it is / isn't something in your customization that is required to trigger this by loading one of the samples to see if it is still slow. The Journalist sample (Help > Samples) would probably be best to try.

    Can you submit a support case to XMetaL Support and provide a sample that demonstrates the issue? If I'm guessing which company you work for correctly then I think you have an XMetaL customization (custom DTD, CSS, CTM, possibly MCR, XFT files, etc). If so, XMetaL Support will need the full customization in addition to a sample XML document(s) to reproduce this.

    If an integration with a CMS is present please also let them know details regarding that integration.

    The McAfee conflict that was present up to the 6.0 release was worked around with our 6.0 SP1 release (the main reason for that service pack). I think that is a red herring if you are running 8.0.

    Reply

    jmblachman

    Reply to: XMetaL Author 8.0 lag

    I did some more testing on my clients machine and I've confirmed that it's not an issue with any customizations or files. I started up XMetaL without loading any documents and just waited. Without fail, about once a minute XMetaL would freeze for about a second, and Task Manager would report it as “Not Respoding”. I even tried closing the open panels such as Resource Manager but no luck.

    I cannot replicate this on my own PC. It only happens with 2 of my clients (out of 4 using XMetaL 8). I don't know what to include in a support case like this…

    Reply

    Derek Read

    Reply to: XMetaL Author 8.0 lag

    Perhaps the difference between your machine and the client is that they have additional files loading at startup? The most common would be macros to initiate the integration with a CMS system but might include other “application-level” macros.

    After installing XMetaL Author on their machines do they modify the installation in any way, either manually or by running an additional installer?

    If you aren't sure you could create a support case with XMetaL Support. They could provide you with an FTP location. You can then zip up the entire XMetaL Author installation and XMetaL Support can diff it against an unmodified installation to see what is changed (or you could do that yourself using a tool like the freely available KDiff3 from SourceForge).

    Reply

  • You must be logged in to reply to this topic.

Lost Your Password?

Products
Downloads
Support