General XMetaL Discussion

XMetaL Community Forum General XMetaL Discussion XMetaL 6 Webtop adapter – Documents not checking out correclty.

  • joe.hopkins

    XMetaL 6 Webtop adapter – Documents not checking out correclty.

    Participants 2
    Replies 3
    Last Activity 12 years, 2 months ago

    We have just deployed XMetaL 6 to our users but have run into an urgent issue.

    Some of our users are experiencing a doOpenForEdit error when trying to edit Documents via the Webtop adapter (see screenshot). The document still gets checked out into a local directory but it does not open automatically. If we do open it via Windows Explorer the document opens in readonly mode even though the document is not readonly (see screenshot).

    Why is XMetaL opening our documents in readonly mode when they are not readonly? We have tried deleting our UCF folder but the issue remains.

    Any help would be much appreciated.

    Our environment:
    Windows XP
    XMetal 6.0.1
    Documentum/Webtop 6.5

    Thanks,

    Joe Hopkins
    AICPCU

    Reply

    pmasal

    Reply to: XMetaL 6 Webtop adapter – Documents not checking out correclty.

    Wish I had an answer for you. Alas, all I can do is back you up. We're having the same exact issue with XMetaL 6.0 in our Documentum 6.5 SP2 environment. Initially we thought it was our ACLs/permission sets but they seem ok (we migrated them from DCTM 5.3 SP5, where they were working fine, and still appear to be the same).

    The checkout appears to occur fine (Documentum Webtop indicates the object is checked out, and the object appears in the local cache). Then when I try to open it in XMetaL 6.0 via file -> open, it opens readonly. So it appears to be an issue with the connector.

    Our XML applications and object model are also the same as they were in DCTM 5.3 SP5, where they worked fine. Any help would be greatly appreciated.

    Paul Masalsky
    EMC

    Reply

    joe.hopkins

    Reply to: XMetaL 6 Webtop adapter – Documents not checking out correclty.

    Hi Paul, I contacted support and they gave me a patch for this.

    Reply

    murray

    Reply to: XMetaL 6 Webtop adapter – Documents not checking out correclty.

    The following provides additional information about the patch and the underlying problem.

    • The problem only occurs in XMetaL Author 6.0.
    • The problem is not dependent on the type of file being checked out. I.e. if a user has this problem checking out a map, they will also have the same problem checking out a topic.
    • The problem is dependent on the Documentum settings for the user that is logged in. I.e. it is possible that user-A will have no problem checking out a file, while user-B will not be able to checkout the same file.
    • The underlying problem fixed by this patch is the following. The connector code incorrectly used a method to get the user id interchangeably with a method to get the user name. If the user’s Documentum settings are such that the user id and user name are the same, everything will work fine. However if they are different the connector will, incorrectly, believe the file is checked out by a different user because it is comparing the user id with the user name and in this case they are different. The patch fixes this by consistently using the same method throughout the code.

    If you believe you are experiencing this problem and would like the patch please contact support and we will send it out to you.

    Reply

  • You must be logged in to reply to this topic.

Lost Your Password?

Products
Downloads
Support