General XMetaL Discussion

XMetaL Community Forum General XMetaL Discussion XMetaL 5/6 compatibility

  • tonys

    XMetaL 5/6 compatibility

    Participants 0
    Replies 1
    Last Activity 12 years, 5 months ago

    A user has reported that people who have installed XMetaL Author 6 are having problem with macros that are working in version 5.5. Are there any known incompatibilities? I don't have version 6, so I can't try it myself.

    Is there a new version of Developer for Author 6? The current version of Developer is difficult to determine from the website.

    Reply

    Derek Read

    Reply to: XMetaL 5/6 compatibility

    There are no known incompatibilities for macros with these two versions, that we know of. The file format of the MCR file is unaltered and we have not removed any APIs. We only ever alter existing APIs to extend them rather than change behavior (we might add an additional option parameter for example, but most of the time we would usually add an entirely new but similar API — hence all the different “paste” APIs for example).

    Probably best to forward the customization you are having trouble with to XMetaL Support together with installation instructions, sample XML file(s), steps to reproduce any particular issue(s) together with a description of what the proper behavior in 5.5 is and how it differs in 6.0.

    XMetaL Developer 6 is not available yet. The release of this product has been delayed until we complete work on XMAX and XMetaL Essential. Once those are done XMetaL Developer will be made available. There will be few changes in XMetaL Developer 6 over the previous release however, with the majority of changes being in the documentation to describe the relatively large number of new APIs in XMetaL Author 6 and XMAX 6, together with related new features (XInclude, etc).

    Reply

  • You must be logged in to reply to this topic.

Lost Your Password?

Products
Downloads
Support