General XMetaL Discussion

XMetaL Community Forum General XMetaL Discussion Whitspaces not appearing in view

  • sethim

    Whitspaces not appearing in view

    Participants 0
    Replies 1
    Last Activity 11 years, 9 months ago

    Hi,

    I've set the 'PreserveSpace' in GlobalPrettyPrintOptions as well as in Element's PrettyPrintOptions but only one whitespace character gets visible in editor mode even though there are continuous multiple spaces which are visible if I switch the document to plain text view.

    Is there any other setting which I need to set ?

    we're using Xmax version 6.0
    Thanks,
    M

    Reply

    Derek Read

    Reply to: Whitspaces not appearing in view

    Two issues with what you are doing:

    1) The section of the CTM file does not support the setting. It is allowed in the per-element settings only.

    2) The setting only controls pretty printing. It does not affect the rendering of Tags On or Normal views. For that you must set the CSS “white-space” setting to something appropriate, probably “pre” in your case.

    XMetaL Developer should guide you in the proper creation of your CTM file, at least letting you get the right settings in there. I assume this means you are editing your CTM file directly with a text editor of some kind. You should be careful not to introduce anything that is unrecognized and that the format is good (at the very least always well formed). For the most part XMetaL Author and XMAX are forgiving when they see something in your CTM that they do not understand, but you could end up causing unexpected behavior as we do not test every possible incorrect combination of options or invalid files.

    Reply

  • You must be logged in to reply to this topic.

Lost Your Password?

Products
Downloads
Support