DITA and XMetaL Discussion

XMetaL Community Forum DITA and XMetaL Discussion WebHelp Search opens in wrong frame

  • mmoulder

    WebHelp Search opens in wrong frame

    Participants 4
    Replies 5
    Last Activity 13 years ago

    When you do a search in the new WebHelp output it open it does not open in the right frame, instead it opens in the whole browser removing the frames. Any thought? If you look at the link properties it is set to open in the same window. I would expect it to open in the right frame.

    Reply

    Derek Read

    Reply to: WebHelp Search opens in wrong frame

    For others reading this thread…

    We have been sent some test files to try to reproduce this now and will try to report on the status of what we find. The issue does not seem to occur for any of the test files we use internally, so at this point I believe something in mmoulder's files must be triggering the problem. Hopefully we'll figure out what that is.

    Reply

    georgerioux

    Reply to: WebHelp Search opens in wrong frame

    I too am having the same issue with the search links opening in a full frame (that is, the frameset disappears and the searched item appears in a full page view).

    As well, the links from the index terms do not work; the path that the index terms point to seem to have an extra set of folders in the path (e.g., it should be here/there/file.html, but it shows up in the output as here/there/here/there/file.html).

    Regards,
    George

    Reply

    Derek Read

    Reply to: WebHelp Search opens in wrong frame

    George, Can you send us your files via standard support?

    This issue seems to be triggered by something in the files that clients are working with. It is not reproducible with the DITA samples that we include that are accessible via the Help > Samples menu items (as far as I know).

    Reply

    Derek Read

    Reply to: WebHelp Search opens in wrong frame

    It looks like one way to trigger this issue is to place some referenced files (images, topics, etc) on a different drive or in a location that is not writeable for you or something that needs to resolve to a full path (rather than relative path which it can be if it is on the same drive). This may trigger these files to be copied to a path that is different than what was specified in the generate output dialog, which in turn seems to trigger the files to open in a different browser.

    I'm still trying to figure out the exact setup required here so I can write this down more clearly.

    Reply

    [email protected]

    Reply to: WebHelp Search opens in wrong frame

    “As well, the links from the index terms do not work; the path that the index terms point to seem to have an extra set of folders in the path (e.g., it should be here/there/file.html, but it shows up in the output as here/there/here/there/file.html).”

    Has the WebHelp Index issue been resolved – in my testing of WebHelp from 6, I'm getting the same issue – the path from an Index link has doubled some of the folders. All of my files are within the same parent directory (or children of). I noticed the XMetaL 6 WebHelp Index seems to work…

    Thank you.

    R Palmer

    Reply

  • You must be logged in to reply to this topic.

Lost Your Password?

Products
Downloads
Support