DITA and XMetaL Discussion

XMetaL Community Forum DITA and XMetaL Discussion TopLeaf – Composition failed: error 1039

  • Wim Hooghwinkel – iDTP

    TopLeaf – Composition failed: error 1039

    Participants 4
    Replies 5
    Last Activity 10 years, 1 month ago

    Hi,

    just installed topleaf and my first atempt to publish a ditamap fails:

      ERROR: 001 – can't open –
              C:WorkJustSysSamplesgendata.ditamap
    IN FILE: C:/PROGRA~3/TopLeaf/DITAmap/pagetypes.def, LINE: 1

    any idea?

    I noticed that TopLeaf uses the OT, I thought it was ment to be an alternative to the OT?

    thanks,

    Reply

    tonys

    Reply to: TopLeaf – Composition failed: error 1039

    The message implies that the file either does not exist or is unreadable. If you're sure that this isn't the problem, can you provide more information about what you are doing? For example, do the other output formats of XMetaL publisher work correctly?

    The data files are normally copied into an OT temp directory after pre-processing, so this path isn't one that I would expect to see in normal usage.

    It's better to think of TopLeaf as an alternative to XSL-FO; it still uses parts of the OT to do the complex non-XML processing required by DITA (just as the XSL-FO processors do).

    Reply

    Wim Hooghwinkel – iDTP

    Reply to: TopLeaf – Composition failed: error 1039

    Hi Tony,

    yes, default PDf publishing in XMetaL works normal – I did a test with the garage sample.

    Reply

    tonys

    Reply to: TopLeaf – Composition failed: error 1039

    OK, but do other output formats work for the data that gives an error in TopLeaf, and is all of the content present? One possibility is that you have a bad link in your data that TopLeaf is reporting, but the other processing is ignoring.

    Reply

    iweyers

    Reply to: TopLeaf – Composition failed: error 1039

    Hello Wim and Tonys,

    I am running into the same problem and was wondering whether you have found a solution for this? I am certain that there are no bad links in my document (I tested on a ditamap with only one very simple concept topic). Another reason why I do not think a bad link is causing this problem, is because I get the same error when composing the provided DITAmap template in TopLeaf GUI.

    I hope you have found a solution and can help me on my way…

    Thank you!

    *Also see my own plee for help: [url=http://forums.xmetal.com/index.php/topic,2985.0.html]http://forums.xmetal.com/index.php/topic,2985.0.html[/url].*

    Reply

    gjn2066

    Reply to: TopLeaf – Composition failed: error 1039

    Hi All,

    I've noticed that this thread (and the other iweyers request) have apparently gone unresolved.

    Could you both send me:

    • the version of the Plugin you are using (6, 7 or 8);
    • the version of TopLeaf that is running (eg. 7.6.032)
    • the version of XMetaL (7.0/8.0)
    • the stylesheet you are using

    I may need additional info later to finalise this, but that will be a good start.

    Regards,
    Geoff

    Reply

  • You must be logged in to reply to this topic.

Lost Your Password?

Products
Downloads
Support