General XMetaL Discussion

XMetaL Community Forum General XMetaL Discussion String copy crashes XMetaL

  • dmurphy

    String copy crashes XMetaL

    Participants 3
    Replies 4
    Last Activity 1 year, 3 months ago

    I'm using XMetaL 12 Author Enterprise. Pasting the following string into a paragraph (or even a codeblock) causes XMetaL to crash every time:

    cluster-acl deny-principal [force|allow-host |deny-host |operation ]

    Any ideas why?

    Reply

    Derek Read

    Reply to: String copy crashes XMetaL

    I can't seem to reproduce this with any files we provide out of the box: DITA, the Journalist sample, etc, but…

    Where are you copying that content from?

    That is going to make a difference. How XMetaL Author handles what it is asked to paste depends on what is on the Windows clipboard, and that will vary widely depending on which application added it onto the clipboard.

    Which document type are you pasting into?

    That is going to make a big difference as XMetaL Author handles some things on its own (natively) but it can be extended using script to handle more clipboard content types, and to handle the content in different ways, modify it before pasting, perform transformations on it, as well as perform actions after pasting.

    The view you are pasting the content into is going to make a difference as well: Tags On, Normal or Plain Text.

    Reply

    dmurphy

    Reply to: String copy crashes XMetaL

    Hi Derek,

    It doesn't seem to matter from where I copy it. I've copied it from NotePad++, from Slack, and even from this forum. I am pasting it into a reference-type DITA topic (although it doesn't matter the topic type). I had only tried it in tags on view. I just tried it in plain text view. XMetaL does not crash when I paste it in plain text view, but when I try to switch back to tags on view, it says “Unknown tag name. The tag name “PrincipalType:name” is not defined.”  It does not switch back to tags on view unless I remove the string. So evidently, even if it's pasted into a codeblock, it interprets it as a tag.

    Several people in our organization have tried this. They all reported that XMetaL crashed as soon as they paste the string. Is there some way to enclose that type of content so it is not interpreted as XML tags?

    Thanks,
    Dana

    Reply

    XMetaLOldTimer

    Reply to: String copy crashes XMetaL

    Hi Dana,

    This issue was reported to us by a partner in March and repaired in our latest release, 14.0.  Are you able to upgrade to v14.0?

    Regards,
    Addam

    Reply

    dmurphy

    Reply to: String copy crashes XMetaL

    Maybe in the near future. Thanks for the reply, Addam.

    Reply

  • You must be logged in to reply to this topic.

Lost Your Password?

Products
Downloads
Support