DITA and XMetaL Discussion

XMetaL Community Forum DITA and XMetaL Discussion stopping XMetaL from automatically creating new lines around column 80

  • yz

    stopping XMetaL from automatically creating new lines around column 80

    Participants 1
    Replies 2
    Last Activity 12 years ago

    It seems that XMetaL (XMetaL 6 Author) creates new lines around column 80 for better readability. However, this new line breaks our DITA–>Confluence script when it happens within title text and within a few other XML tags. I can go into the Plain Text View and fix this, but the moment I switch to another view, XMetaL automatically reformats the text again. Is there any way to stop this??? I expected an option somewhere related to auto-reformatting, but no luck so far. Thanks for the help!

    Reply

    Derek Read

    Reply to: stopping XMetaL from automatically creating new lines around column 80

    You have Pretty Printing turned on (I believe that is the case in most recent versions as far as DITA functionality is concerned). For DITA (only) you can turn Pretting Printing on and off with two scripts in the list of macros in the Macros toolbar.

    If you wish to keep Pretting Printing on but require specific settings that are different from what we ship then this can be configured by modifying the appropriate CTM file. This is not something I would expect a regular user of XMetaL Author Enterprise working with DITA to be able to do so it would be best to submit a case to XMetaL Support that includes a sample document in the state you wish to see it in. They might be able to provide a tweaked CTM file for you. However, if significant changes are needed then you might need to contract this work to the XMetaL Professional Services team.

    Note: for other document types (anything but DITA) it is up to the person that created the customization to configure this in the CTM file (which is usually done using XMetaL Developer).

    Reply

    yz

    Reply to: stopping XMetaL from automatically creating new lines around column 80

    Great. Turning off Pretty Printing solved my issue completely. Thanks!

    Reply

  • You must be logged in to reply to this topic.

Lost Your Password?

Products
Downloads
Support