General XMetaL Discussion

XMetaL Community Forum General XMetaL Discussion Special characters not displayed correctly

  • lqian

    Special characters not displayed correctly

    Participants 7
    Replies 8
    Last Activity 12 years, 10 months ago

    Hi,

    I have inserted some special characters in xml file. Some of the special characters are not displayed correctly in both plain text view and normal view, like non breaking hyphen(‑). Some display fine only in plain text view, e.g. one third(⅓) and two third(⅔). Some display correctly in both plain text view and normal view, like one eighth(⅛).

    Can any one tell what is the reason causing this problem? Thank in advance.

    Reply

    dcramer

    Reply to: Special characters not displayed correctly

    Me too. I get square blocks with these characters:

    ↵ (carriage return symbol)
    ⇦ (left arrow outline)
    ➝ (Heavy triangle-headed rightwards arrow)

    Reply

    Derek Read

    Reply to: Special characters not displayed correctly

    Your customization needs to be configured to use a font that contains glyphs for these characters (and all the other characters you need to render in your document). This is done using the CSS property called font-family for all the elements that will contain these characters in your XML document. If you have a nicely designed CSS file that might just mean setting font-family on the root element so all other child elements will inherit that setting (as per the standard CSS cascading rules).

    To find a font containing glyphs for those characters do one of these things:

    1. Paste your text into Windows Notepad. Select Format > Font to open the Font dialog and cycle through all the fonts on your machine until all the characters are rendered as you like.

    2. Find a font containing glyphs for your characters at this website:
    http://www.fileformat.info/info/unicode/char/search.htm

    Enter the proper Unicode name (or portion of it) or the hex value, such as 21b5

    Example: http://www.fileformat.info/info/unicode/char/21b5/index.htm

    3. Repeatedly modify the CSS file(s) being used in your XMetaL customization to change the font-family value and then refresh the XML document.

    Here's an example (DITA document) that uses “Arial Unicode MS” as the preferred font. I have this font installed and so XMetaL uses it to render the text in these

    elements:
    [img]http://forums.xmetal.com/index.php?action=dlattach;topic=511.0;attach=167;image[/img]

    “Arial Unicode MS” is sort of the Holy Grail for fonts for me as it contains the vast majority of glyphs required to render most characters defined in the Unicode Base Multilingual Plane (first 65,536 characters of Unicode).

    PlainText view is not controlled using CSS. The font used to render this view is set in the main Options dialog: Tools > Options > Plain Text View (tab)

    Reply

    dcramer

    Reply to: Special characters not displayed correctly

    Ok, so the fallback system isn't supported? e.g.

    font-family: Verdana,”Arial Unicode MS”,sans-serif;

    David

    Reply

    Derek Read

    Reply to: Special characters not displayed correctly

    Fallback is supported but means something different in our product as compared to some web browsers.

    In our case, the first font found in the list is used, full stop. When a font higher in the list is not available the next listed available one is used. There is no support for “I found most of the characters I need in this font, but not all of them so I'm going to start hunting for the rest in other fonts”. That would be a nice feature but it isn't implemented.

    Reply

    lqian

    Reply to: Special characters not displayed correctly

    Thanks for the prompt response.

    After I changed my default font setting to Arial Unicode MS in CSS, all special characters rendered correctly in normal view.

    Reply

    lefrac01

    Reply to: Special characters not displayed correctly

    The unicode characters for prime and double prime are not being displayed in XMax 7.0 with the Univers font (licensed font, full name “Univers LT Std 55”).  A box with an X in it is shown.  Example of text: 58º35′89″

    I tried with word 2010 and the characters show up ok with this font.  Same goes for the skype chat client.  If I change the font to Georgia in XMax then they show up correctly. 

    What could be causing this?  Is there any possible workaround?

    Reply

    Derek Read

    Reply to: Special characters not displayed correctly

    Is this the Linotype font “Univers 55 Roman”? If so, it does not define glyphs for those characters as far as I can tell.

    You can test that here by entering any sample text you like into their text page for this font: https://www.linotype.com/1212822/univers-55-roman-product.html

    If other software is displaying characters that are not in this font then they must be substituting another font for the missing characters.

    You will need to specify a font for this particular document type that contains all the characters needed to display the content your authors will be authoring. It sounds like Georgia is one option.

    Reply

    lefrac01

    Reply to: Special characters not displayed correctly

    Thank you for your reply, Derek.

    Yes, it is the font you identified and lo and behold when I use charmap.exe these symbols are in fact not defined.

    Reply

  • You must be logged in to reply to this topic.

Lost Your Password?

Products
Downloads
Support