DITA and XMetaL Discussion

  • dianamost

    Server Busy Message??

    Participants 3
    Replies 4
    Last Activity 13 years, 8 months ago

    When I run a local build (from a batch file), there is I an error message: 

    “Server Busy – This action cannot be completed because the other program is busy. Choose 'Switch to' to activate the busy program and correct the problem.”

    Switch To and Retry buttons are on the popup. Selecting Switch to pops up the Start menu in Windows.

    Anyone know why this is happening? It could my my configuration, as the batch files were created by developers here who support our DITA documentation.

    Thanks in advance….

    Diana

    Reply

    ghkrause

    Reply to: Server Busy Message??

    Diana,
    which program are you running? XM Author or XMAX? Do you have any ActiveX objects in your code (your developers should know). I do not know this very error message but we have a similar dialog with drag and drop of files where ActiveX object is in JScript for XM Author 5.1 Enterprise Ed. The trick for us -as we do not run a batch- is to drag over task bar to get focus on XM Author and then finally drop the file we want to open or link.
    Hope this helps to go the next step.

    Reply

    Derek Read

    Reply to: Server Busy Message??

    This message is thrown up by Windows when it detects that an application is not responding to COM requests. Given that this is likely being triggered by custom code it would be impossible to state why this is occurring exactly, only that whatever is being called is taking “too long” (or not responding at all). It would be best to check with your developers. They may be able to rewrite the script or application (possibly a DLL) that is involved (ideally so that it responds faster).

    If they are unable to do so, it is possible (depending on what they are doing exactly) to increase the amount of time before such a message appears using the following XMetaL Author INI variable setting:

    ole_server_busy_timeout =

    The default value is 8 seconds:
    ole_server_busy_timeout = 8000

    This is only effective when a script is being run directly from within an XMetaL Author MCR file and that script is calling a COM object.

    Note that if this is affecting XMAX there is no similar fix as XMAX does not currently support the equivalent of this INI variable setting.

    Reply

    arjunanatha

    Reply to: Server Busy Message??

    I am also often getting a 'server busy' message when I paste formated text into an XMetal XML document using XMetal Author Enterprise 5.5.0.219. Pasting the text in via TextPad is a workaround but this is rather clunky.

    First I get the dreaded 'egg timer' cursor for a few seconds, then I get the dreaded 'Server Busy' 'dialog' giving me the useful options of either 'Switch To…' or 'Retry'. 'Cancel' is grayed out. Opting for either just repeats the 'Server Busy' 'dialog'. Opting for either just repeats the 'Server Busy' 'dialog'. Opting for either just repeats the 'Server Busy' 'dialog'.

    Actually, the only option is the three-fingered salute and kill XMetal.

    Ideas anyone?

    Reply

    Derek Read

    Reply to: Server Busy Message??

    arjunanatha: are you working with DITA documents (I know you posted in this board but just double checking).

    If so, can you provide a sample of what you are pasting? If this is a repeatable issue then it should hopefully be possible to reproduce it easily on another machine (and I'd like to try). The more information you can provide about what you are pasting (exactly) and where you are pasting to (perhaps provide a sample file) the better.

    Reply

  • You must be logged in to reply to this topic.

Lost Your Password?

Products
Downloads
Support