General XMetaL Discussion

XMetaL Community Forum General XMetaL Discussion Pretty Printing not being applied to Table elements

  • 4fingers

    Pretty Printing not being applied to Table elements

    Participants 0
    Replies 1
    Last Activity 14 years ago

    I have XMetaL Author Essential 5.5 and have been editing the CTM file so that I get indentation in the text view. It seems to work on everything except Tables:

    When I create a table in tag view and go into text view I see this:


    I then have to place spaces in between the elements in order to trigger the indentation:


    Once I switch back to text view the table is nicely indented:





    If it helps here is the section in the CTM file that specifies how the Table should be formatted:

        Cell in the body of a table

        Table row

    It must be something to do with my CTM file as the Journalist template has no problems formatting Table elements.



    Derek Read

    Reply to: Pretty Printing not being applied to Table elements

    If pretty printing is being applied but only after you manually introduce whitespace that sounds like a bug to me. I can't reproduce this in 5.1 so I'll load up 5.5 when I get a minute and see if it is specific to that version.

    If you can provide your schema and a sample XML document to XMetaL Support it that would be best. In theory it should not make a difference, but if this is due to a bug then it might.

    There's nothing wrong with your CTM settings that I can see, provided that what you show in your “the table is nicely indented” section is what you actually want (there are far more pretty printing settings available).


  • You must be logged in to reply to this topic.

Lost Your Password?