General XMetaL Discussion

XMetaL Community Forum General XMetaL Discussion PDF build failure: build.xml:94

  • LM

    PDF build failure: build.xml:94

    Participants 0
    Replies 1
    Last Activity 8 years, 5 months ago

    Hi, I am trying to generate output and keep getting an error. I am new to XMetal, so I am learning as I go…
    Using XMetal Author Enterprise 8.0.0.036

    My problems started when we switched from McAfee to ESET Endpoint Security. XMetal would crash as soon as I opened it. We found out that McAfee did not do a clean removal of files… We got it working, but now I cannot generate output to the XMetal Enhanced PDF via RenderX XEP delivery type.

    The log file says build failed with this error… DITA_OTbuild.xml:94

    What am I looking for to fix this? Is it something in the build.xml file? I assumed it meant line 94 which is

    Reply

    LM

    Reply to: PDF build failure: build.xml:94

    We figured it out. I'm only posting this to give ideas for others running into the same errors…

    When IT updated our security from McAfee to ESET Endpoint security XMetal stopped working. It crashed with the following error:
    Script Error: Unable to determine ClassID for language “VBScript”
    We searched forums and found this: http://forums.xmetal.com/index.php?topic=503.0
    Those solutions did not work so we thought that the switch to ESET was disabling the VBScript somehow.

    We ended up uninstalling and reinstalling XMetal (Since I'm not familiar with the original setup or configuration, we made copies of the existing files we thought we needed)
    We determined that McAfee did not do a clean job of removing files. IT ran a short script from McAfee to fix that.
    The app crash stopped, and files would load but could not generate output.
    This error displayed: DitaRenditionsImpl…configureOutputEx: Error code: -2146828212 Path not found.
    And then the log files said that output was unsuccessful due to build.xml:94

    Turns out another guy had the original setup files in a SoftQuad folder, so we copied them over to mine. I guess this was a case of missing files, because it worked.
    My next quest to to understand how XMetal and the DITA OT work together and what files are needed to make it turn.

    Reply

  • You must be logged in to reply to this topic.

Lost Your Password?

Products
Downloads
Support