DITA and XMetaL Discussion

XMetaL Community Forum DITA and XMetaL Discussion Output failed when building PDFs

  • rde

    Output failed when building PDFs

    Participants 1
    Replies 2
    Last Activity 11 years ago

    I'm using XMetaL Author Enterprise Version#: 6.0.1.030

    XMetaL had been beautifully outputting PDFs for me in three languages (en, jp, and cn) until a couple of weeks ago when I didn't need to do any doc builds for a while. Today I tried building a set of DITA files that I have built many times before–files I have not changed since I last built successfully–and I got a build failed error (see attached image).

    I have five sets of DITA documentation that I regularly build PDFs from with XMetal, and none of these are working now. None of the DITA files in any of those projects have changes since I last built successfully. I have not tweaked any files in the DITA_OT folder since I last built successfully. I did install a content management system from SDL Trisoft that uses XMetal, but that installation occurred almost two months ago and I've been successfully building PDFs using XMetal since installing the CMS.

    Has anyone seen the Build Failed dialog box (attached) or the errors (also attached) that I am seeing? Derek (or someone else on the JustSytems team) if you could look at the dialog box and the errors to tell me what might be wrong, I would much appreciate it. I have a doc deliverable in a week that depends on building a PDF with XMetaL.

    Thanks,
    Rick

    Reply

    [email protected]

    Reply to: Output failed when building PDFs

    Hi,

    I faced this problem as well. After integrating a specialization module, i tried to validate and generate output from a sample ditamap. Xmetal showed me the same error mentioned in this thread.

    I tried to change the output location a couple of times. Once it generated the PDF and CHM with topics missing from it. At other instances it failed to generate the output.

    Regards,
    Sudhir

    Reply

    barbwire

    Reply to: Output failed when building PDFs

    Well, that image, which contains errror says it clearly:

    SaxParseException: premature end of file

    It basically means, that your xml file is empty or it has some kind of syntax error or your xml file does not exists. Try to make sure, that your xml file(s) are okay.

    Especially ch or jp could bring some special characters, which MAY cause your problems.

    Reply

  • You must be logged in to reply to this topic.

Lost Your Password?

Products
Downloads
Support