General XMetaL Discussion

  • JoAnne

    odd changes

    Participants 3
    Replies 4
    Last Activity 11 years, 1 month ago

    XMetaL Enterprise 6.0.1 on Windows 7 Pro SP1 64-bit

    Yesterday XMetal was the same as always, and today when I generate, the files are different. For HTML/Webhelp, suddenly the HTML files are generated in the main folder and instead of having the file names like “t_how_to.html” they have names like “rad7BB69_tmp.html”, temporary files are no longer deleted, and when I look in Tools > DITA options > General, there are no domains listed at all to hide or show, even though the DTDs are in the DTDs folder.

    I didn't change anything. Any idea what could cause this? I tried starting XMetaL with CTRL held down to clear the cache, but that didn't help.

    Thanks, as always.

    Reply

    gcrews

    Reply to: odd changes

    I think that hapes when you have the sandboxing  output option on the advanced tab set to yes

    cmd_fs_sandboxing=yes
    cmd_cms_sandboxing=yes

    you might check thoes

    Reply

    JoAnne

    Reply to: odd changes

    Thanks, that seems to have fixed it

    But I'd love to know why/how it changed in the first place.

    Reply

    Derek Read

    Reply to: odd changes

    If you install a CMS system integration it might change this setting. Other than that I cannot think of anything that would do it.

    Reply

    Derek Read

    Reply to: odd changes

    One other reason you may wish to set this value to yes is if you name your DITA files using characters that are valid but that the DITA OT will choke on (Windows only prohibits a small set of characters from being used in file names).

    The DITA OT is happy with a-z, A-Z, 0-9, some basic punctuation marks, hyphens, underscore and other characters, but if you choose file names that use other characters (such as those used in Greek, Russian, Thai, Chinese, etc…) the DITA OT may have issues producing output.

    Our Japanese localized version of XMetaL Author Enterprise 6.0 ships with the setting cmd_fs_sandboxing=yes for this reason (because most people in Japan will use Japanese file names and that will break the DITA OT).

    Reply

  • You must be logged in to reply to this topic.

Lost Your Password?

Products
Downloads
Support