General XMetaL Discussion

XMetaL Community Forum General XMetaL Discussion Macro shortcut and icon disabled

  • paul_cpwr

    Macro shortcut and icon disabled

    Participants 0
    Replies 1
    Last Activity 10 years, 10 months ago

    I've noticed after our recent upgrade to XMetaL 6.0 that I can't change the icon or keyboard shortcut for a macro.  I can open the Macros dialog via the Tools > Macros command but the “Shortcut key” area and the “Choose Image” buttons are disabled. Is there something I can do to enable these features?

    All of the macros I want to modify were developed by me. Some of them are application macros and the rest are doctype-specific macros. I'm having this problem with both kinds of macros.

    I'm running XMEE 6.0.2.070 and have run into this behavior on both Windows XP and Windows 7. The doctype in question is a DITA doctype and I have the latest DITA 1.2 customization kit installed. This didn't feel like it was DITA-specific behavior, so I pose the question here.

    Best regard,

    Paul Anderson
    Compuware Corporation

    Reply

    Derek Read

    Reply to: Macro shortcut and icon disabled

    For several versions now (since the first version to support Vista) XMetaL Author Essential and Enterprise do not allow writing to files in the install path, typically C:Program FilesXMetaL…

    Newer versions of Windows (after XP) do not allow this unless you reduce their security settings.

    So, unless an MCR file is located outside this location (in a location that can be written to) writing to it will not be allowed, and this dialog will disable functions associated with making modifications to any macros in that file.

    [quote=InstallReadme.html]Configuring XMetaL Author for Local Admin privileges

    XMetaL Author Enterprise is installed with the assumption that users have Limited User account privileges under Windows. If you need to set up DITA specializations for your end users, or if you want to enable features that are otherwise disabled for Limited Users you must set the following variable in the XMetaL Author configuration file (xmetal60.ini): user_setting_mode=default

    Local Admin users very familiar with the product may continue to work with XMetaL Author Enterprise in this mode, however, we recommend that it only be used to accomplish tasks that cannot be done otherwise and that the default setting be restored once these tasks are accomplished.

    The default setting is the “per-user” mode, which is set as follows: user_setting_mode=per_user

    Reply

  • You must be logged in to reply to this topic.

Lost Your Password?

Products
Downloads
Support