DITA and XMetaL Discussion

XMetaL Community Forum DITA and XMetaL Discussion Loosing Content References using Documentum adapter

  • joe.hopkins

    Loosing Content References using Documentum adapter

    Participants 3
    Replies 4
    Last Activity 11 years, 11 months ago

    One of our users is losing content references in her XML files.

    She has parent.xml and child.xml.

    child.xml has content references to parent.xml

    After she edits parent.xml sometimes child.xml loses the references to parent.xml… So when she checks out child.xml she gets the following error (attached screenshot).

    Environment:
    Windows XP
    XMetaL(R) Author Enterprise 5.5 (Version#: 5.5.0.219)
    XMetaL(R) Author Enterprise for Documentum Webtop (Version#: 2.0.0.066)
    Documentum 6.5 Sp1

    Reply

    pmasal

    Reply to: Loosing Content References using Documentum adapter

    What version of XMetaL EE for Webtop are you using, and for what level of Documentum?
    We were having similar issues with XMetaL EE 5.5 and DCTM 6.5 SP1. We had to request a patch, then all was ok.
    Paul Masalsky
    EMC

    Reply

    joe.hopkins

    Reply to: Loosing Content References using Documentum adapter

    Thanks for the response pmasal. I am not sure I understand your question. What do you mean by what level of Documentum? My post has the version listed under environment.

    Thanks!

    Reply

    pmasal

    Reply to: Loosing Content References using Documentum adapter

    I'm sorry, I didn't see that you provided all the required information (didn't scroll down far enough).

    I think you're encountering the same issue with Reusable Components/conrefs that we had. If so you need a macro that can be placed in your C:Program FilesXMetaL 5.5AuthorStartUp folder to allow the references to work.

    I would send the macro and install instructions, but because this was created specifically for us, I would recommend that someone from JustSystems Support send the required fix, because there were some stipulations about using the macro, and there might have been additional developments in this area. Addam Smith and Ning Hu (both from JS development) helped us out and they would likely be able to help immediately.

    Paul Masalsky
    EMC

    Reply

    joe.hopkins

    Reply to: Loosing Content References using Documentum adapter

    I was able to resolve the issue. She had changed

    tags to tags. XMetal requires that the elements with the conref attributes must be of the same type that they are referencing.

    Thanks for the feedback pmasal.

    Reply

  • You must be logged in to reply to this topic.

Lost Your Password?

Products
Downloads
Support