General XMetaL Discussion

XMetaL Community Forum General XMetaL Discussion Issue in Image rendering

  • pooh2583

    Issue in Image rendering

    Participants 3
    Replies 4
    Last Activity 8 years, 11 months ago

    Hello,

    I am using Xmetal Author 7

    I want to render an image into xml Document using Xmetal , I am writing attribute in .ctm file where source is one of the attribute value which is the name of the image ,and the image itself is copied into the folder where xml document is present.

    when image is loaded for the first time only X is present in place of an image.

    but when I change the View of the xml file in Xmetal like tag view and again switch back to normal view the image is rendered and shown in the Xmetl document properly.

    Could you please guide me about this issue?

    Also I am writing a code in CSS where I have to show bullet image in palce of an actual bullet.
    I am writing following code for that

    element:before {content:url(bullet.jpg);} then only X is shown in place of image(bullet.jpg is copied where css files are)
    and when I put the whole path of the image like

    element:before {content:url(D:imagebullet.jpg);
    image is shown properly.

    Could you please let me know the solution for writing the relative path , where excactly i need to copy the image?

    Reply

    Derek Read

    Reply to: Issue in Image rendering

    This problem with your customization files sounds like something that doesn't really make sense to try fix on the forum.

    Please submit separate support cases (one for each issue) to XMetaL Support together with the customization (all files required to reproduce your issue). XMetaL Support can then try to figure out what is coded incorrectly in your CTM and CSS.

    Note that the CSS you have written here is correct, so there must be a path issue, or the CSS file is corrupt or something else is going on there. XMetaL Support will be able to tell you once they see your full customization.

    Reply

    pooh2583

    Reply to: Issue in Image rendering

    Hello,

    I can not provide the entire css file for some reasons,but I can assure you taht .css file is error free .

    Following is the exact content of my css for the element

    element:before {
    content:url(D:imagebullet.jpg);
    }
    and with the above code image is properly visible in Xml document in Xmetal

    but when I copy bullet.jpg where my .xac file is present and write
    element:before {
    content:url(bullet.jpg);
    }
    image is not visible instead an X is visible.

    Could you please help me with this?

    Reply

    Derek Read

    Reply to: Issue in Image rendering

    The only way to help you at this point would be to reproduce your issue. Please submit a support case with your customization files and a sample XML file to XMetaL Support. If there is a specific location you are deploying files to please provide that information.

    Reply

    Donna111

    Reply to: Issue in Image rendering

    Hi there
    I am a beginner in Xmetal.I also want to know that if there is any [url=http://www.rasteredge.com/how-to/csharp-imaging/]image processing[/url] tool which supports to render image with XMetal.
    I need to render some image to pdf files.Thanks for any suggesitons.

    Reply

  • You must be logged in to reply to this topic.

Lost Your Password?

Products
Downloads
Support