General XMetaL Discussion

XMetaL Community Forum General XMetaL Discussion How can I get the spell checker to work in XMetaL 6

  • Anonymous

    How can I get the spell checker to work in XMetaL 6

    Participants 4
    Replies 5
    Last Activity 11 years, 6 months ago

    We just recently upgraded to XMetaL 6. The spell checker no longer checks the document, nor does the spell as you type feature work.

    The spell checker appears, but it just tells me it's done. Even when I know there are spelling errors, it won't flag them.

    The Check spelling while typing option is on.

    I've selected main and user word lists.

    I've selected English as the language.

    What am is missing?

    Many thanks,

    Lynne Van Wagenen
    FamilySearch

    Reply

    Derek Read

    Reply to: How can I get the spell checker to work in XMetaL 6

    There is nothing else to do. Short of uninstalling and reinstalling (perhaps it is not properly installed) it would be best to provide us with a sample document containing misspelled words so we can try to reproduce this issue here. We would need to know the document type as well and obtain a copy of your DTD so you may wish to submit this to XMetaL Support in this case.

    Reply

    Derek Read

    Reply to: How can I get the spell checker to work in XMetaL 6

    I see that this is an upgrade. There is a known issue when upgrading from 5.5 to 6.0 but that causes a crash (more severe than just “not working”).

    The issue is that the files used for the spell checker in 5.5 differ quite a bit from 6.0, but the 6.0 installer does not properly upgrade them. When XMetaL 6.0 asks the 5.5 spell checker to do things it can't do (the spell as you type feature) it crashes. The solution for this particular issue is to force XMetaL 6.0 to install the 6.0 spell checker files by following the steps outlined here: http://forums.xmetal.com/index.php/topic,983.0.html

    If you aren't seeing crashes then you seem to have a different issue. However, you should still perform those steps to be sure.

    Reply

    vanwagenenl

    Reply to: How can I get the spell checker to work in XMetaL 6

    I've tried uninstalling and reinstalling. I also tried the fix you suggested in the other post. I'm still having the same problems.

    I'm using plain-old DITA. No specializations.

    The spell as you type feature works with my translated files. I can pull up a German file and see the red wavy line beneath some words. It seems to use the correct dictionary for the language. If it were using the English dictionary, most words would be marked with red.

    Should I submit a case?

    Reply

    vanwagenenl

    Reply to: How can I get the spell checker to work in XMetaL 6

    I think I've figured it out. Our templates specify the xml:lang tag incorrectly as en_US instead of en-US.

    The spell checker works correctly when I either remove that attribute or correct it. I guess it would make sense that the program uses that attribute to determine which dictionaries to use.

    Reply

    Derek Read

    Reply to: How can I get the spell checker to work in XMetaL 6

    Detail on this feature located here: http://forums.xmetal.com/index.php/topic,539.0.html

    This feature was new to 6.0 and did not make it into the docs. See the section on INI settings in case you wish to continue to use en_US.

    Reply

  • You must be logged in to reply to this topic.

Lost Your Password?

Products
Downloads
Support