DITA and XMetaL Discussion

XMetaL Community Forum DITA and XMetaL Discussion Getting an Output Failed Error each time I try to generate anything in XMetaL

  • carmstrong

    Getting an Output Failed Error each time I try to generate anything in XMetaL

    Participants 3
    Replies 4
    Last Activity 11 years ago

    Hello. I am using XMetaL 6.0.2.070. My output was working fine last week, but currently, every time I try to generate a ditamap or even a topic, I get the following error message (please see attachment).

    “The deliverable could not be created. If a file with the same name is open in another application, close the file and then generate output again.”

    In an attempt to address this issue, I have deleted all of the contents in the pdf_out folder and have verified that the file(s) is not open anywhere. The output log file is not entirely helpful, so I'm not sure why I can't generate anything now. Any ideas would be most helpful.

    Thanks,
    Crystal Armstrong

    Reply

    gcrews

    Reply to: Getting an Output Failed Error each time I try to generate anything in XMetaL

    Have you tried generated to a different folder? My guess is the I: drive is a network drive and someone else or some other application may have the pdf file locked.

    Reply

    carmstrong

    Reply to: Getting an Output Failed Error each time I try to generate anything in XMetaL

    Yes. I've tried generating to a different folder. That worked only once, though. I even had someone else on my team try generating it and using a different folder. We both got the same error. 

    Reply

    carmstrong

    Reply to: Getting an Output Failed Error each time I try to generate anything in XMetaL

    I'm not sure what's happening. There haven't been any recent updates to my PC or XMetaL. I'm attaching the output log with the errors I received for review. I noticed I'm getting the [java] ERROR on all of my output attempts, not just one particular document. Any information you can provide would be helpful. Thanks.

    Reply

    Derek Read

    Reply to: Getting an Output Failed Error each time I try to generate anything in XMetaL

    There are a few things here that, even if they are not the cause of this particular issue, should be corrected.
    You have an @href that is pointing to this location: “http://msdn.microsoft.com/en-us/library/bb763170.aspx” which is clearly not a DITA file (even if it is the DITA OT is going to assume it is not). To avoid this error the @formatattribute should be changed to something other than “dita” or “xml”.

    In addition, the errors where you are referencing files that cannot be found should be easy to correct. I would also go through the rest of this list of errors and correct as many of the others as possible.

    If you have made changes to the DITA OT then that could be part of the issue. The last 12 errors suggest that (though the DITA OT might be confused by something else). If changes have been made then it might be easiest to submit a support case to XMetaL Support and include the files that are required to produce output as you are doing it (all your changes to the DITA OT and some sample files) so that they can try to reproduce you setup and trigger the same errors.

    Reply

  • You must be logged in to reply to this topic.

Lost Your Password?

Products
Downloads
Support