DITA and XMetaL Discussion

XMetaL Community Forum DITA and XMetaL Discussion Generating PDF fails in Windows 7/XMetaL Author Enterprise 8

  • Kris

    Generating PDF fails in Windows 7/XMetaL Author Enterprise 8

    Participants 1
    Replies 2
    Last Activity 9 years, 4 months ago

    Hi,

    I ran into a problem when I tried to generate PDFs with XMetaL Author Enterprise version 8.0.0.036 on a new laptop that runs 64-bit Windows 7.

    The build fails because it can't find the stage2.fo file. Actually, XMetaL does generate the file but for some reason it places it into the
    SoftQuadXMetaL%20SharedDITA_OTtemp folder instead of
    SoftQuadXMetaL SharedDITA_OTtemp. Basically, it creates a new file outside the “regular” temp folder, which is why it can't find the stage2.fo file for going on with the build process.

    I tried to copy stage2.fo to the regular temp folder during PDF generation but then XMetaL does the same thing with stage3_topic.fo: it ends up in the new temp folder and the build fails again.

    Has anyone ever experienced this issue?

    I can generate PDFs alright on another computer and webhelp is generated OK even on this laptop, so I'm sure the problem is not with my map or XML files. Unfortunately, I’m stuck with this company laptop so I have to use this one for PDFs as well.
    I have admin rights on the Win 7 laptop and even if I try the “Run this program as an administrator” trick it fails to build a PDF. The only thing I realized is that I can't change/delete files in the Program Files (x86) folder. I'm not sure if that's important at all.

    Any help is greatly appreciated.

    Thanks,
    Kris

    Reply

    Derek Read

    Reply to: Generating PDF fails in Windows 7/XMetaL Author Enterprise 8

    We think we know what the issue is. Do you see the following message when you generate output?

    ---------------------------
    XMetaL Author Enterprise
    ---------------------------
    Output could not be generated. The Windows registry value HKLMSYSTEMCurrentControlSetControlFileSystemNtfsDisable8dot3NameCreation must be set to "0" (default). Files created while this setting was not "0" may need to be rewritten.
    ---------------------------
    OK 
    ---------------------------

    Either way, if you see the error or not, please check to see if the following value is set in your registry*:
    HKEY_LOCAL_MACHINESYSTEMCurrentControlSetControlFileSystemNtfsDisable8dot3NameCreation = 0

    In order for the DITA Open Toolkit integration with XMetaL AUthor Enterprise to function properly that value must be set to create 8.3 file names.

    It is a little more complicated than just changing the value however, because that Windows setting affects files and folders [u]only[/u] when they are [u]created[/u]. You will need to do the following:

    1. Change the value for the following registry setting to 0 (meaning create 8.3 file names): HKEY_LOCAL_MACHINESYSTEMCurrentControlSetControlFileSystemNtfsDisable8dot3NameCreation
    2. Reboot your machine.
    3. Remove the deployed copy of the DITA OT so that it can be redeployed (causing the 8.3 filenames to be created). You can do this one of two ways:

    A) Delete the folder %appdata%SoftQuadXMetaL SharedDITA_OT
    The next time you generate output the DITA OT will first be redeployed (depending on the speed of your machine you may see a progress bar).

    Many people cannot see their %appdata% folder (it is hidden by default for most Windows accounts) and will need to do the following:

    B) Use the XMetaL UI to force redeployment (essentially this does the same as A above):
      1. Launch XMetaL Author Enterprise.
      2. Select Tools > Configure Output to open the Configure Output Options dialog.
      3. On the Advanced tab find this parameter and increment the value (from 1 to 2, 2 to 3, etc):
          cmd_dita_ot_per_user_version = #
      4. Click OK to dismiss the Configure Output Options dialog.
      5. Either generate output or select Tools > Configure Output again.
      6. When asked if you would like to upgrade the DITA-OT version select OK.
          The DITA OT will be re-deployed from the installed version
          (%Program Files%Common FilesXMetaL Shared) overwriting any
          existing copy in %appdata%SoftQuadXMetaL Shared

    * As far as I know the 8.3 file name creation setting is 0 by default on Windows 7. On some systems values other than 0 and 1 may be supported, so you might see 2 or 3 instead. The value 0 means that 8.3 file names will always be created and that is the preferred value. The 8.3 file names will also be created with 2 or 3 but when to do so is controlled by volume in that case.

    If you did not alter this value yourself please check in with your IT people to see if there was a specific reason for setting it to the value it is set to. However, setting the value to 0 should not affect any software as that is the most compatible setting (long file names continue to be created in all cases). The only supposed advantage to changing the value from 0 to another setting is to improve the speed at which files are created. However, in all tests I have read about (there are some long threads arguing about this) the improvements are negligible or nil.

    Reply

    Kris

    Reply to: Generating PDF fails in Windows 7/XMetaL Author Enterprise 8

    Hi Derek,

    You were right, I had to change this value from 2 to 0 and now it works OK.
    Thanks for your help.

    Kris

    Reply

  • You must be logged in to reply to this topic.

Lost Your Password?

Products
Downloads
Support