DITA and XMetaL Discussion

XMetaL Community Forum DITA and XMetaL Discussion Excessive CPU when opening Xmetal with documents from last session.

  • gcrews

    Excessive CPU when opening Xmetal with documents from last session.

    Participants 4
    Replies 5
    Last Activity 11 years, 10 months ago

    Running Xmetal Author Enterprise 6.0.1.030 with 6.0.1.039 XFRunner.dll
    I tested with the original 6.0.1.030 dll and it appears to do the same thing.

    Noticed a weird issue today, when I open Xmetal and it opens up one DITA file from my last session it takes about 50 seconds to open.  I have no maps open and no other documents. If however I open Xmetal after closing it with nothing open it opens in about 3 seconds and I can then open that same document in about 3 seconds. Attached in a screenshot of the CPU usage during certain operations. I also attached the DITA document I was working with.  I removed any internal information with generic text; it now takes about 26 second to open when Xmetal open but takes less than 3 seconds to open it after Xmetal has started. I tried disabling the spelling while typing to.

    Seems like something stepping on itself while Xmetal is loading. Has anyone else noticed this?

    Reply

    Derek Read

    Reply to: Excessive CPU when opening Xmetal with documents from last session.

    Doesn't occur for me. Roughly 2+ seconds in both cases for me, perhaps slightly longer when launching XMetaL but not more than 1 second.

    Maybe you have left a map open and it is being reopened as well? You might not notice that if it was open in the Map Editor (in the Resource Manager) but you closed the Resource Manager). The Map Editor will open the map in this case but you will not see it because the Resource Manager is hidden.

    If you are using a repository then the initial connection to the repository at application startup can take some time depending on the CMS software and the responsiveness of the server/network itself. Or you might have other 3rd party integrations loading into XMetaL at startup (I assume you would be aware of these things though).

    Reply

    gcrews

    Reply to: Excessive CPU when opening Xmetal with documents from last session.

    Hum, try with the document in tag view. Normal view does not seem to have the issue.

    Also try with “Refresh references when opening DITA topics” checked in the dita options.
    When its unchecked xmetal starts and loads the file instantly. When its checked it goes into the CPU spasm and takes forever to start up. Even though that document does not have any references it seems to effect the loading.

    I don't have any maps open or any other documents.

    1.Open XMetal
    2.Close everything
    3.Open just test.xml
    4.Switch to tag view
    5.Close Xmetal
    6.Open xmetal

    I attached two more dita file with less tagging to try and see whats causing it.
    The only difference between the two attached files is that I moved the ul list outside the definition list.
    test8s.xml
        loads in 8 seconds when loading when xmetal starts.
    test25s.xml
        loads in 25 seconds when loading when xmetal starts.

    Both files load in about a second if i open them after xmetal has started witch takes about 4 seconds by itself.

    Reply

    Derek Read

    Reply to: Excessive CPU when opening Xmetal with documents from last session.

    Still can't reproduce it. No matter what I do on this machine both files open in all views in less than 3 seconds, including starting up XMetaL.

    I'll try a few other machines when I get some time. Perhaps this machine is too fast for me to notice a difference. I'll see if I can set up a VMWare with low memory and bog it down somehow so that things slow down enough to notice.

    Reply

    gcrews

    Reply to: Excessive CPU when opening Xmetal with documents from last session.

    Hum, I don't know what else it could be then.
    I did a test in vm with same results shown in the screen shot attached.

    First hump in the center of the task manager wasxmetal loading.
    Second hump was opening document and switching to tag view.
    Third hump was closing xmetal with document still open.
    long hump after three large bumps was re-opening xmetal after closing it.
    last long hump was opening it again to get a screen shot when its opening.

    Here is the setup I did:
    1. Created vm with 1024mb of ram and 2 cores.
    2. installed xp sp3
    3. installed .net framework 3.5 sp1.
    4. installed xmetal (XMAU-ENTERPRISE-6.0.1.39.exe)
    5. opened xmetal
    6. opened test25s.xml
    7. closed xmetal
    8. reopened xmetal

    Reply

    gcrews

    Reply to: Excessive CPU when opening Xmetal with documents from last session.

    Any update, have you had a chance to look into this anymore? I can’t think of anything unique about our systems that this problem would only be affecting up.  We have resorted to disabling of opening pervious documents since it takes so long to reopen Xmetal  if anything was open before.  Has anyone else noticed the long loading of documents when Xmetal opens?

    Reply

  • You must be logged in to reply to this topic.

Lost Your Password?

Products
Downloads
Support