DITA and XMetaL Discussion

XMetaL Community Forum DITA and XMetaL Discussion Error in Document Type Declaration in the document

  • kwag_myers

    Error in Document Type Declaration in the document

    Participants 2
    Replies 3
    Last Activity 11 years, 5 months ago

    I think I broke something…again. I was playing around with this: [url=http://forums.xmetal.com/index.php/topic,431.msg1720.html#msg1720]http://forums.xmetal.com/index.php/topic,431.msg1720.html#msg1720[/url] in an effort to get My Assets going (it's a slow day here in the mire). Anyway, in Windows 7, the only way to edit the XMetaL60.ini file is to change some permissions. I couldn't get it to work, but now when I attempt to open a file in XMetaL it opens in Plain Text View with an error:

    “Error in Document Type Declaration in the document: Unable to create rules file. The file C:Program Files (x86)XMetaL 6.0AuthorDITAXACsconceptconcept_ditabase.rlx could not be created.”

    I've tried changing everything back the way it was (to the best of my recollection) and restarting my machine. Any suggestions (besides the obvious: stop playing with stuff you know nothing about)?

    Reply

    Derek Read

    Reply to: Error in Document Type Declaration in the document

    Actually, you can add options to the following file and they should override (cumulatively) settings inside the copy installed next to XMetaL60.exe:

    %appdata%SoftQuadXMetaL6.0xmetal60.ini

    Having said that, I suspect your issue is that you have removed the following setting that tells XMetaL you are running as a user with less than full permission to write files anywhere you like (the default behavior of Windows XP):

    user_setting_mode=per_user

    This is set by default and will be required on almost any version of Windows 7 (where people are usually “limited users”). If you log in as a local admin and turn UAC off you can get away without having it installed. With this setting enabled XMetaL writes any files it would otherwise write to a read only location (such as C:Program Files) into the following “per user” location instead (which is what you want): %appdata%SoftQuadXMetaL6.0gen

    Reply

    kwag_myers

    Reply to: Error in Document Type Declaration in the document

    Ah, I see the problem – underscore, not hyphen. Su-Laine Yeo has “…per-user…” in her (previously mentioned) post. Changing the hyphen to an underscore has solved the issue. I should also mention that this was causing XMetaL to go unresponsive on closing. This, too, has been resolved.

    Thanks again.

    Reply

    Su-Laine Yeo

    Reply to: Error in Document Type Declaration in the document

    Sorry about the hyphen vs. underscore mixup. I've just corrected it in the original post. Thanks for catching this.

    Su-Laine

    Reply

  • You must be logged in to reply to this topic.

Lost Your Password?

Products
Downloads
Support