DITA and XMetaL Discussion

XMetaL Community Forum DITA and XMetaL Discussion Display conkeyref value when not opened from map

  • marg

    Display conkeyref value when not opened from map

    Participants 1
    Replies 2
    Last Activity 6 years, 7 months ago

    If I open a DITA topic that uses @conkeyref content, how can I associate a specific key with it, so it can show the correct content?

    I know that if I open the map that has the key definition, and then open the topic from there, it (usually) knows which content to use. But without the map, how can I tell XMetal the right keyspace to use? I've tried various things under the Reuse menu but could not get this to work.

    The DITA files and maps are coming out of an SDL LiveContent repository. Using XMetal Author Enterprise 9.



    Derek Read

    Reply to: Display conkeyref value when not opened from map

    When you open a DITA topic that references a key space XMetaL Author Enterprise will prompt you (by default) with a dialog like this:

    Associate a Key space

    Would you like to associate a key space to use with this DITA
    document? If you do, then key references can be resolved and
    displayed inline.

    [ ] Never prompt to associate a key space again

                                            [Associate]   [Don't Associate]

    Note that it includes a checkbox labeled “Never prompt to associate…” (as shown above). If you have ever checked that box that setting will have been remembered and you will not be prompted. To enable these prompts go to Tools > DITA Options, and on the Update Content tab enable the checkbox on the bottom left of that dialog labled “Prompt if the document is not associated with a key space when automatically refreshing references”.

    You will also not be prompted if you have unchecked the checkbox labeled “Refresh references when opening topics” in that same DITA Options dialog (that setting is enabled by default so you would need to have disabled it).

    If you click Associate the “Add Key Space” dialog will open. You can use this to associate a key space with the topic. See the steps below, starting in this case at step 3.

    Alternatively, if you already have a DITA topic open:
    1. From the Reuse menu select Show Key Space Manager (the last option in the menu).
    2. If you have a map open that contains key spaces you can just select one from the dropdown list at the top of that dialog. If you don't have a map open then select the Add button.
    3. A dialog named Add Key Space will open. In that dialog select the first button labeled Browse and select the map that contains a key space you want to associate. If your documents are stored in a CMS then an additional checkbox should be displayed in this dialog that lets you browse for files located in a CMS*. You will need to check that box.
    4. After selecting a map click OK to dismiss that dialog and associate the key space.
    5. Click the close button on the Key Space Manager dialog.

    * For this to work, at least in the way XMetaL has designed it to work, the CMS connector (aka: CMS bridge) must be built using the “XMetaL Connector” SDK so that the DITA authoring functionality can interoperate with XMetaL Connector, which in turn handles the communications with the CMS. I don't think this is the case for the SDL connector. Check with SDL support to see if the version you have is using XMetaL Connector, and if it is not which newer version might be.



    Reply to: Display conkeyref value when not opened from map

    A-ha! Thanks for the answer. You're right, my version of the SDL Authoring Bridge (11.1.2) does not seem to access the SDL repository in this situation. In your step 3, when I click Add Key Space and then click Browse to open a map, nothing happens, even if the checkbox “Browse from repository” is selected. I'm going to open an SDL bug or feature request on that.

    So I am going to tell my users they need to open the map with the keyspace first, and then open the topic from there to see the proper conkeyref content.



  • You must be logged in to reply to this topic.

Lost Your Password?