General XMetaL Discussion

XMetaL Community Forum General XMetaL Discussion Delete key is not working in XMetal Author

  • biswajitsr

    Delete key is not working in XMetal Author

    Participants 2
    Replies 3
    Last Activity 10 years, 11 months ago

    I am using XMetal Author in my project and have done some customizations in it's code. I am using XMetal 6.0. I am facing a problem that sometimes “delete” key is not working in XMetal author right pane. But sometimes it is working. As I don't have any customization code to lock delete key, so it is working sometimes.  Can anyone give me some idea, what might be the reason behind it. Thanks in advance.

    Reply

    Derek Read

    Reply to: Delete key is not working in XMetal Author

    Can you explain a little bit more what you mean by “right pane”?

    Reply

    biswajitsr

    Reply to: Delete key is not working in XMetal Author

    By right pane I want to mean the document editing area where the document appears.

    In XMetal Author there are two areas side by side. The one is the left pane i.e. the resource manager and the rest is the document area where we can view or edit the document.

    If I am not still clear to you then please let me know.

    Reply

    Derek Read

    Reply to: Delete key is not working in XMetal Author

    OK. First thing I would try is to eliminate your customization as the problem. To do that you can open another one, such as the Journalist sample: File > New > Journalist (tab) > Article (template).

    Does the same thing occur there?
    – No: there is a pretty good chance that this is a document-level customization issue specific to your customization. Most likely candidates are MCR or CTM files included with your DTD / XSD.
    – Yes: you may have an application-level customization issue affecting all document types. Most likely candidates are MCR files in the Startup folder.

    In both cases debugging your customization is probably the quickest way to resolve this. You may also wish to simply eliminate any MCR files and see if that resolves the issue (then concentrate only on the MCR file that triggers this issue when it is present).

    It is possible that you have found a bug, but we have nothing noted here in our bug tracker. The delete key is working just fine as far as I can tell in my testing, with no other reports from clients having a similar issue either.

    Reply

  • You must be logged in to reply to this topic.

Lost Your Password?

Products
Downloads
Support