DITA and XMetaL Discussion

XMetaL Community Forum DITA and XMetaL Discussion Configure Key Space Association

  • Scibert

    Configure Key Space Association

    Participants 9
    Replies 10
    Last Activity 10 years, 4 months ago

    In XMetaL 7.0 Author Enterprise, the Configure Key Space Association dialog appears whenever a file is opened outside the Map Editor. Is there a way to prevent this (annoying) behavior?

    Reply

    Derek Read

    Reply to: Configure Key Space Association

    You have two options:

    1. Uncheck the checkbox marked “Prompt if the document is not associated with a key space when refreshing references” in Tools > DITA Options on the tab named Update Content.

    2. If you do not need to author to the DITA 1.2 standards you can configure the product to author to the DITA 1.1 DTDs. This will cause it to use the old dialogs and functionality from XMetaL Author Enterprise 6.0 (they do not have support for key space or other new DITA 1.2 features). The option is in Tools > DITA Options on the General tab and is called “Select Default DITA Version”. Set the value to “1.1”.

    Reply

    Scibert

    Reply to: Configure Key Space Association

    Hi Derek,

    Thanks! Both of these solutions work.

    Cheers

    Reply

    August

    Reply to: Configure Key Space Association

    I would never have been able to discover this checkbox if it were not for this post. In my version of XMetal, the text for the checkbox is not readable.

    I'm running XMetaL(R) Author Enterprise 8.0 Service Pack 1. When I go to Tools > DITA Options >Update Content, I see the checkbox labled (sic):
    [ ] when refreshing references.Prompt if the document is not asso

    That's it, verbatim. The text is cut off and I cannot figure out how to resize the subwindow of the dialog. The text also looks like it was never proofread by anyone who writes grammatical English: unlike every other checkbox in the dialog, it does not start with a capital letter, there is no space between the period and the following sentence, and the initial clause is not a complete sentence so a period and a capital letter are incorrect as well.

    Sloppy text like that makes me think I'm using a Beta version, not a Service Pack 1 version. If it's a Beta, I can understand the text not fitting in the window and being sloppily written as well. But it's not a Beta.

    IS THERE ANY TRICK for resizing the subwindow of this dialog so that the whole text for the checkbox can be read? I would never have been able to discover the meaning of this checkbox if it were not for this post that gives the whole text.

    Reply

    Derek Read

    Reply to: Configure Key Space Association

    @August:

    There is no 8.0 SP1 'beta' so that isn't your issue. It sounds to me like the text controls in the dialog containing that text are somehow being drawn in the wrong position. Why there might be two controls for one piece of text I'm not sure, but that's what it sounds like.

    “when refreshing references.Prompt if the document is not asso”
    vs
    “Prompt if the document is not associated with a key space when refreshing references”

    I am unable to reproduce this issue here with 8.0 SP1 or 9.0 and I'm not sure what would trigger that.

    Reply

    barbwire

    Reply to: Configure Key Space Association

    I have same kind of problems. I attached example picture.

    Reply

    Derek Read

    Reply to: Configure Key Space Association

    This looks like a font issue that development was looking into fixing for version 9.

    I have never seen it on any of my machines but I suspect it is because this form asks for a specific font that isn't there (in your case) and the substitute that Windows chooses is too big or bold or something similar. Or the form was coded to allow Windows to select its default font, but that default font is different on these machines either because our Windows installations include extra fonts that Windows decides to use, or clients that see this have setups that include fewer (than the Windows default fonts) resulting in the same behavior.

    If anyone sees this issue with version 9 that would be good to know.

    Reply

    barbwire

    Reply to: Configure Key Space Association

    This looks like a font issue that development was looking into fixing for version 9.

    If anyone sees this issue with version 9 that would be good to know.

    Derek, that screenshot was from version 9. 🙂 Version 9.0.0.024 to be exact. 🙂

    Reply

    Derek Read

    Reply to: Configure Key Space Association

    OK, well I guess whatever they tried didn't fix this particular issue.

    Can you provide a list of the fonts (a directory listing of file names from C:WindowsFonts) installed on your machine?

    Here is the content of a .bat file that should write a txt file into your per-user TEMP folder:

    [code=.bat file to write out list of font files]c:
    cd C:WindowsFonts
    dir *.* > %temp%fontlist.txt
    pause[/code]

    To get to that folder after you run the batch file you can enter %TEMP% into the Windows Explorer address bar.
    If you want to write elsewhere just change the path in line 3.

    Then export the Fonts registry key and send the text content as well. It think that key is usually (always?) here:
    HKEY_LOCAL_MACHINESOFTWAREMicrosoftWindows NTCurrentVersionFonts

    If you don't want to post that information here please submit a support case.
    Hopefully this will give us a clue when I compare it to a working system here. That assumes my guess is correct.

    Reply

    barbwire

    Reply to: Configure Key Space Association

    Attached.

    Reply

    ToeBar

    Reply to: Configure Key Space Association

    Attached [url=http://www.intermediaarts.org/]is this awesome Hydromax review[/url].

    Thanks for the fonts barbwire. Just what I needed.

    Reply

  • You must be logged in to reply to this topic.

Lost Your Password?

Products
Downloads
Support