DITA and XMetaL Discussion

XMetaL Community Forum DITA and XMetaL Discussion ConditionalTextExporter error

  • jsd2az

    ConditionalTextExporter error

    Participants 0
    Replies 1
    Last Activity 9 years, 9 months ago

    Workaround:
    To get around this issue I saved the ditamap to a different name. No more issue.

    ~~~~~~~~~~~~~
    No hits came up in the search engine for this so here goes. I'm trying to generate but before it makes the attempt, I get the error:
    ConditionTextExporter.prototype.exportSettings….:
    Error code: -2146828218
    Permission denied.

    Then it begins to try and generate only to end with the following error and prompt to open the log file:

    “The deliverable could not be created. If a file with the same name is open in another application, close the file and then generate output again.”

    There is no file open with the same name as I'm trying to generate, and upon opening the log file, the only outlined error item is:


    transform.fo2xmpdf.xep:

    [echo] transform.fo2xmpdf.xep start

    [java] ERROR: Attribute 'text-align' cannot have a value of “char”.

    [java] Rendering failed: Invalid XSL FO source 'file:/C:/TFS_PH-W-JDWORACZ/TechComm/pdf_out/production3/topic.fo': 1 error found during validation

    [java] Java Result: 1

    [echo] transform.fo2xmpdf.xep end

    I tried renaming the topic.fo file but when it creates a new one the same error appears.
    I'm using version Version#: 6.0.1.030

    Reply

    Fa

    Reply to: ConditionalTextExporter error

    Hi!

    Thanks for posting your workaround, I just ran into the same issue. I'll try to rename the map.

    Cheers!

    Reply

  • You must be logged in to reply to this topic.

Lost Your Password?

Products
Downloads
Support