DITA and XMetaL Discussion

  • bzebian

    Colons in Index Terms

    Participants 3
    Replies 4
    Last Activity 12 years, 11 months ago

    Is there any way to delimit a colon in an indexterm marker so that it doesn't create a sub-term in the index, but displays as an actual colon? Yahoo DITA Users group says use : but that doesn't seem to work.

    This is with the pdf3 output type in XmetaL 5.1

    Reply

    Su-Laine Yeo

    Reply to: Colons in Index Terms

    Hi Bob,

    As far as I can tell, this is an Open Toolkit issue and is not specific to XMetaL. I'm surprised that nobody has reported it before.

    I've logged a bug here against the Open Toolkit: https://sourceforge.net/tracker/?func=detail&aid=2879196&group_id=132728&atid=725074

    As a primitive workaround, depending on what font you are using in your PDF index you might be able to use another character that looks like a colon. Here is one that should work in a few fonts: http://www.fileformat.info/info/unicode/char/05c3/browsertest.htm

    Regards,
    Su-Laine

    Reply

    Su-Laine Yeo

    Reply to: Colons in Index Terms

    Derek found this old thread in which someone posted a creative workaround for the bug: http://tech.groups.yahoo.com/group/dita-users/message/9598

    Reply

    bzebian

    Reply to: Colons in Index Terms

    Thanks. Will give them a test.

    Reply

    bzebian

    Reply to: Colons in Index Terms

    I've found that if I type the term in the Sort As box in the Insert Index Marker dialog, it does not break at the colon in PDF output. For example, Connect:DirectConnect:Direct

    prints correctly in the index as Connect:Direct. That may be easiest for the writers to handle.

    But I find that doesn't work with commas. The only thing I've found so far that works for commas is to insert the indexterm from the element list rather than through the 5.1 GUI.

    index, item

    Also, looks like when you use Sort As with EclipseHelp output, it outputs the term twice. We disable the index tag in Eclipse output, so this is not a big deal.

    Reply

  • You must be logged in to reply to this topic.

Lost Your Password?

Products
Downloads
Support