DITA and XMetaL Discussion

XMetaL Community Forum DITA and XMetaL Discussion Cannot generate output, XMetaL 8.0, from DITA source

  • grenley

    Cannot generate output, XMetaL 8.0, from DITA source

    Participants 4
    Replies 5
    Last Activity 9 years, 3 months ago

    I have two installations of XMetal, installed on two Windows machines a day or two apart.

    The first installation is on Win7 under Parallels on a Mac, and works just fine.

    The second installation is on a Dell running Win 7, and was downloaded and installed from behind our corporate firewall. The second installation works in all respects, except it cannot generate PDF or HTML. This first installation can.

    So what's the difference? Did our corporate firewall block downloads of some FO, or other ancillary files? Or is there somewhere else I should look?

    George

    Reply

    gcrews

    Reply to: Cannot generate output, XMetaL 8.0, from DITA source

    By “cannot generate”, do you mean the output progress dialog shows but the green progress bar does not and XMetaL becomes unresponsive? If so try restarting. That’s the issue that has plagued us for years…

    Reply

    grenley

    Reply to: Cannot generate output, XMetaL 8.0, from DITA source

    My bad. Should have been more specific.
    No progress bars. It almost immediately throws an error. Error code: 2146828235 File not found.
    Screen caps attached.

    Reply

    grenley

    Reply to: Cannot generate output, XMetaL 8.0, from DITA source

    Hello? Any suggestions? I have two installations, both paid for in full. One works, the other doesn't. And yes, why not just use the one that works? Corporate security rules.

    It appears I am missing files that define how output is to occur, but I don't know where those files might be.

    Any suggestions?

    Reply

    Derek Read

    Reply to: Cannot generate output, XMetaL 8.0, from DITA source

    It is possible the DITA Open Toolkit is broken or an old version is being run. If you upgraded from XMetaL Author Enterprise 7.0 then your installation may be trying to run the version of the DITA OT deployed by your installation of 7.0. Redeploying the DITA OT should correct this.

    It is also possible that the copy we include with 8.0 has been modified. In that case please check with the people at your organization responsible for making such changes.

    You can redeploy the DITA OT one of two ways:

    A) Delete the folder %appdata%SoftQuadXMetaL SharedDITA_OT
    The next time you generate output the copy installed with 8.0 should be redeployed.

    Note that because many users can no longer see their %appdata% folder you can use the following procedure instead.

    B) Use the XMetaL UI to force redeployment (essentially this does the same as A above):
     1. Launch XMetaL Author Enterprise.
     2. Select Tools > Configure Output to open the Configure Output Options dialog.
     3. On the Advanced tab find this parameter and increment the value (from 1 to 2 for example):
       cmd_dita_ot_per_user_version = 2
     4. Click OK to dismiss the Configure Output Options dialog.
     5. Either generate output or select Tools > Configure Output again.
     6. When asked if you would like to upgrade the DITA-OT version select OK.
         The DITA OT will be redeployed from the installed version
         (%Program Files%Common FilesXMetaL Shared) overwriting any existing
         copy in %appdata%SoftQuadXMetaL Shared

    If this does not correct the issue then there are probably settings in one or more files in the following folder that are causing problems. If these have been altered on purpose check with the people that made those changes. Deleting this folder will allow defaults to be generated. Shut down XMetaL Author Enterprise before deleting this folder.
    %appdata%SoftQuadXMetaL8.0

    In this case, if you are unable to view or modify your own %appdata% folder you will need to ask your IT people for permission or help.

    If you still have problems please submit a support case via XMetaL Support. They will need to gather more information about your installation and configuration in order to figure out what is broken.

    Please also read [url=http://forums.xmetal.com/index.php/topic,384.0.html]About the Forum[/url]

    Reply

    grenley

    Reply to: Cannot generate output, XMetaL 8.0, from DITA source

    Thanks for taking the time to post a detailed fix. I'm sorry to say neither step worked. I was able to to delete both directories, and I restarted both Win7 and XMetaL, but i get the exact same message, whether I try to output PDF or HTML or whatever.

    I will open a trouble ticket, per your suggestion.

    Reply

  • You must be logged in to reply to this topic.

Lost Your Password?

Products
Downloads
Support