General XMetaL Discussion

XMetaL Community Forum General XMetaL Discussion Cannot disable Key Space Association dialog in XM9

  • mpanhuijsen

    Cannot disable Key Space Association dialog in XM9

    Participants 3
    Replies 4
    Last Activity 7 years, 2 months ago

    Using XMetaL Author Enterprise 9, I want to refresh content references in my topic so I right-click and select Refresh All References.

    XM now pops up a dialog “Associate a Key space” asking me if I want to associate a key space with this document. I don't; in fact, I don't want to see this popup ever again.

    The Tools > DITA Options dialog has an Update Content tab. It has  a checkbox “Prompt if the document is not associated with a key space when automatically refreshing references.” Sounds like just the ticket, but the box is not checked. I checked it and then unchecked it, and restarted XM just to be sure. The dialog keeps appearing. How do I get rid of it?

    Reply

    bjorn

    Reply to: Cannot disable Key Space Association dialog in XM9

    Verify that the dita_options.xml in  C:UsersUsernameAppDataRoamingSoftQuadXMetaL9.0 is set to

    FALSE

    When this is FALSE, you should not be prompted with the  “Associate a Key space” dialog box again.

    Maybe there also is a API for this?

    Bjørn

    Reply

    royjanssen

    Reply to: Cannot disable Key Space Association dialog in XM9

    Here the same, after refreshing rererences the key Space Association dialog appears.
    We are using Xmetal 9.0.0.053

    The dita_options.xml -> FALSEIt looks like the application ignore this option.

    Reply

    barbwire

    Reply to: Cannot disable Key Space Association dialog in XM9

    Here the same, after refreshing rererences the key Space Association dialog appears.
    We are using Xmetal 9.0.0.053

    The dita_options.xml -> FALSEIt looks like the application ignore this option.

    1. Tools / Dita Options
    2. Tab “Update Content”
    3. Uncheck under “key based references” “Prompt if the document is not associated with a key space…”

    Reply

    royjanssen

    Reply to: Cannot disable Key Space Association dialog in XM9

    Thanks for your feedback!
    Even when we Uncheck the “key based references” update selectbox the dialog doesn't disappear.
    The dita_options.xml contains for the configuration option “KSAssocPromptForRefresh” the value FALSE.

    Reply

  • You must be logged in to reply to this topic.

Lost Your Password?

Products
Downloads
Support