DITA and XMetaL Discussion

XMetaL Community Forum DITA and XMetaL Discussion Adding a catalog file.

  • bjorn

    Adding a catalog file.

    Participants 0
    Replies 1
    Last Activity 8 years, 3 months ago


    I trying to  add a catalog file for our dita dtd, mod and ent files. I using this(http://xmetal.com/webhelp/en/xmetaldeveloper/cg/7.0/locations_of_catalog_files.html) webhelper site to try to configure and place the catalog file correctly.
    I tried all the different file locations described in the webhelper site, but none the catalog files get active on XMetaL startup.

    Is there any additional config I need to edit in order to get this to work?




    Derek Read

    Reply to: Adding a catalog file.

    The documentation you point to is correct but XMetaL Developer documentation is generally not relevant to the DITA authoring customization. Specific things other than just catalog entries need to be set up when it comes to authoring DITA. For most cases that's already all done without the need to make changes.

    The other case (that I can think of) is if you are working with specialized DITA DTDs and in that case there is an automated process that does everything necessary to set up the environment. If that is what you are doing then (adding specialized DITA DTDs) then you should be following the instructions in XMetaL Author Enterprise's Help (F1) under the topic Working with DITA > DITA Specializations (as listed in the Help's “Contents” tab).

    If you do feel you need to check if your catalog entries are being loaded enable the following INI settings and have a look at the log file at the path you specify after launching XMetaL Author Enterprise or after opening an XML file:
    make_log_file = true
    log_file = C:some_writable_folderxm_lookup.log

    You may see entries added at launch and you should see entries added with each XML file opened.
    But also keep in mind that when it comes to DITA the catalog entry look-up is special and entries in this log file will not help you much.


  • You must be logged in to reply to this topic.

Lost Your Password?