Home Forums DITA and XMetaL Discussion Issue when trying to create Chinese output Reply To: Issue when trying to create Chinese output


Reply to: Issue when trying to create Chinese output

Hello Derek,

Thank you for your answer. As I said in my original post I tried “Book via RenderX” out of curiosity, but again out of curiosity, I tested editing the pdf2 font mapping to correspond to what I have in the xep.xml file, and I got a much better result: I got most of the Chinese text, except for a few glyphs that did not display (I get the “missing character” symbol aka square), which I could then fix by extending the character range in i18N for zh_CN.

Regarding the “XMetaL enhanced pdf via RenderX XEP”, my previous version of XMetaL was 6.0. I don't know what version of DITA_OT it used, but yes, there have been a lot of changes at least in how the folders and files are structured. What I did to get my customizations back was to use a diff tool to see everything I had done to the DITA_OT provided with XMetaL 6.0 by comparing the original DITA_OT folder with the one I had customized (and also the xep.xml file). I thought I had successfully transferred all my modifications to the DITA_OT2.2pluginscom.xmetal.xmfo folder, where I believe the changes for pdf via renderX should be made.

Most of the changes have been successfully implemented (page size, fonts used, etc.), even Russian works: I get the output with no error. I have not yet tried producing other Asian languages I work with, but that's my next step (Japanese, Thai, Vietnamese). I'll see if these work or if I get the same issue as with Chinese. 

For most of the files, I have edited them to reflect the changes I had made for XMetaL 6.0, but I might indeed have, for one or two files, just copy/pasted (overwritten?) them instead of editing their equivalent in DITA_OT2.2. I will check, but I don't remember overwriting many files.