Home Forums DITA and XMetaL Discussion XMetaL 11 Unable to resolve paths with file:// Reply To: XMetaL 11 Unable to resolve paths with file://

Fa

Reply to: XMetaL 11 Unable to resolve paths with file://

I also have a very similar issue (in XMetaL 11 too).

I have created a small DITA map with a few topics that I keep always in the same location (a drive on our intranet, mapped on my computer). This DITA map (let's call it ComRef, for common references) will then be included in all my manuals (indented or embedded or however you want to call it in my manual DITA maps). The idea, since this is general information, is that if there is something to be updated, we correct it once here, and then any manual we generate subsequently will get the updated info.

Then I have created a template for my manuals. This template is a DITA map with several topics, and in it I have embedded the ConRef map (well, a link to it). The idea is that I can take that template and copy it anywhere on my local machine or network and it would work. This means I should be working with absolute paths, where by default XMetaL creates a relative path to the ConRef map (is there any way to change that?).

Unfortunately this ConRef map is not rendered in the pdf output. The only thing that works is if the embedded ConRef map is in the same folder or a subfolder of where my template map is, which defeats the purpose.

What I have tried unsuccessfully:

– Change the ConRef map path from relative to absolute.
– Change the reference to the map to topicref instead of mapref (XMetaL 6.0 created a topicref for embedded maps, so I gave it a shot)

I have tested this with my old XMetaL 6.0, and there there was no issue. The output pdf is created without problem and has the embedded ConRef map material in it.

I now finally seem to have solved it (partially). The trick was to work my way through the path of both maps and renaming everything so as not to have any space (in the folder names but also in the map names). At least this worked with a relative path, I still have to test with an absolute path. But this is very unpractical! I have thousands of folders, so I cannot obviously be expected to rename them all.

Anyway, hope this will help you and maybe put you on the right track to solve your own issue…

Regards

Reply

Products
Downloads
Support