Home Forums DITA and XMetaL Discussion Leading spaces in PDF outputs Reply To: Leading spaces in PDF outputs

Derek Read

Reply to: Leading spaces in PDF outputs

DITA documents are “pretty printed” by XMetaL Author Enterprise by default when you save from Tags On or Normal view. If you do not want this additional white-space to be added to your DITA XML source documents you will need to disable the pretty printing feature.

To turn off pretty printing for the DITA authoring solution run the macro titled “DITA Configuration: Turn OFF Pretty-Printing”.

The DITA Open Toolkit (both the copy we install with XMetaL Author Enterprise and the one available directly from the SourceForge DITA OT project) handles “insignificant white-space” (what we add for “pretty printing”) fine in every case I have seen. I suspect this means your client is either not producing output using the DITA OT, or they have modified the DITA OT so that it is no longer capable of properly dealing with it.

Reply

Products
Downloads
Support