Home Forums General XMetaL Discussion Problems with toolbars Reply To: Problems with toolbars


Reply to: Problems with toolbars

I think I'd better start over. We are porting some customizations from 4.6 to 7.0. There are thousands of XML files already created that have the following doctype declaration:

This will obviously no longer work, and the prospect of changing all those files terrifies me. I tried including the following entry in extid.map:

! .*bioguide.dtd “bioguide.dtd”

The files display properly, but the toolbar buttons that call macros in bioguide.mcr are grayed out. I next switched to this:

! .*bioguide.dtd “file://c:/program%20files/xmetal%207.0/author/rules/bioguide.dtd”

When I create a new file, the toolbar buttons are active, but any attempt to open an existing file gets an error about not being able to find the DTD. We have the DTD on the Web, so I tried specifying that instead of the file:// in the entry, but I got the same result. The existing files are not on the same machine as the one I'm running XMetaL on, and there's no way to put them on the same machine, at least not permanently. It almost makes me think the pattern in the extid.map file isn't matching because of the whitespace in the value for the system ID in the existing files. (The system ID value for newly created files has no whitespace in it.) Do you have any suggestions?