Home Forums General XMetaL Discussion How to prevent XMetaL from inserting hard returns in the text? Reply To: How to prevent XMetaL from inserting hard returns in the text?

Derek Read

Reply to: How to prevent XMetaL from inserting hard returns in the text?

The customization* you are using to author your documents has “pretty printing” enabled. Depending on the limitations of the translation service's ability to read XML you may need to disable this feature entirely. You might also be able to have someone design pretty printing so that it is compatible with your translation service.

If you are working with DITA documents there is an easy solution for disabling pretty printing. Run the script named “DITA Configuration: Turn OFF Pretty-Printing” that is listed in the Macros toolbar.

If you are working with any other document type (not DITA) you will need to contact the people that created the customization for you and have them disable pretty printing. Documentation on this feature is discussed in the Customization Guide, but since the settings are all fairly self-explanatory (when working with the CTM editor in XMetaL Developer) this documentation is minimal. Our Professional Services team can help with this if necessary (if the people that created your customization are not familiar enough with the product). If you merely need to disable the feature entirely one simple change to the CTM file is all that is necessary.

XMetaL Support could help with that if you submit a support case together with your customization files to them. If you need help designing pretty printing settings (every element can have different settings) then that would be a Professional Services engagement.

*customization = the files that tell XMetaL how to behave when you are authoring to a particular DTD or XSD Schema

Reply

Products
Downloads
Support