Home Forums General XMetaL Discussion Pasting into XMetal is taking several minutes or doesn’t work on a few PC’s Reply To: Pasting into XMetal is taking several minutes or doesn’t work on a few PC’s

Derek Read

Reply to: Pasting into XMetal is taking several minutes or doesn’t work on a few PC’s

I'm not sure how to begin to try to reproduce this here. Some research on this error would need to be done, but do you know if it is coming from Windows itself, or if you might have some other type of security software installed? Those are the two places I would look first, with the latter maybe being more obvious to spot (if this is separate software).

I think ActiveState (I assume you still probably use Active Perl) has some forums you might have a look at in case this is a known issue with their engine. Otherwise, their support team might help as well.

If the paste is eventually succeeding on some machines as you say, but is taking a long time, that might indicate some type of security software is doing some kind of scanning before allowing your PerlScript to run (and in some cases deciding to block it). These are just guesses however. I don't recall ever hearing about this occuring for you previously so perhaps your IT people have installed something new that is triggering this.

From the description this is not a problem specific to XMetaL but with either PerlScript or the script engine you are using and how it is running (or not being allowed to run) on these machines. To test that and perhaps simplify things or give you another means to track this down, you might create a similar script that will run in an HTML page and load that into IE and see what happens there. I would expect the same behavior.

Reply

Products
Downloads
Support