Home Forums General XMetaL Discussion XMetaL55 Author Resource Manager Reply To: XMetaL55 Author Resource Manager

Su-Laine Yeo

Reply to: XMetaL55 Author Resource Manager

Hi,

I'll address these two issues separately:
– Adding items to the Assets tab
– Line breaks within items in the Assets tab

Items that appear in the Assets tab are stored in a subfolder of C:Program Files . Under Windows Vista many users can't edit files within C:Program Files, so if you are using Vista you probably won't be able to add items to My Assets.

By default, XMetaL is configured to not try to write to C:Program Files, because doing so would result in errors for people who don't have permissions to write to C:Program Files. This means that a few features, including My Assets, are turned off. ¬†However, under Windows XP, or under Vista with appropriate privileges, you can run XMetaL in a mode that will allow you to write to My Assets. We call this the “local admin” mode. To do this:

1) Open the C:Program FilesXMetaL x.xAuthorXMetaLxx.ini file.
2) Find the line that says user_setting_mode=per_user .
3) Change this line to user_setting_mode=default.

Regarding line breaks within items in the Assets tab, it is a known issue that assets containing line breaks cannot be dragged into the document. The possible workarounds are:

РYou could turn pretty printing off in the CTM file. However, this also requires you to remove carriage returns from existing  documents as well because XMetaL Author does not remove pre-existing carriage returns from existing documents after pretty printing is turned off (because it does not presume to know whether you actually want them or not). A script can be written to do that however.

– A manual workaround that appears to resolve the problem is to right click on the asset in the Assets tab, select “copy” and then paste (using Ctrl+V or other method) into the document rather than using a direct drag and drop action. The reason this works is because it bypasses the code specific to the Assets tab feature . Using copy and paste causes XMetaL to use its “normal” method of interpreting what is on the clipboard.

Do these things help?

Reply

Products
Downloads
Support