Home Forums DITA and XMetaL Discussion How to prevent DITA-OT copy to user directory? Reply To: How to prevent DITA-OT copy to user directory?

jperkins

Reply to: How to prevent DITA-OT copy to user directory?

Thank you, Derek. That was a very helpful response. I'd like to ask a follow-up, if I could:

We don't use XMetaL's OT. Instead, we maintain our own version, which gets installed to a different location entirely (we do this because we actually have a suite of tools, and we want them all to use the same OT). For XM5.1, this was as simple as setting a handful of environment variables (DITA_DIR, DITA_OT_DIR, etc.) to the new location.

Is there anything like this for XM5.5? That is, is there something I can set to make it look at C:DITA-OT instead of C:D and SCurrentUserApplication DataSoftQuad…DITA_OT?

If that is possible, then I can set print_local.xml just once and forget about it, and carry on like we did with XM5.1 (which was working very well for us).

Updates:

I tried modifying dita_ot_per_user_location in dita_print.txt but it does not seem to have any effect.

Looking at what is being written to Local Settings/Temp/XMetaL during the transformation, I see that DITA_OT_DIR=C:DITA-OT (correct, for me) in dita.bat, but it gets overwritten in xm_dita_envar.bat.

Reply

Products
Downloads
Support