Home Forums DITA and XMetaL Discussion Server Busy Message?? Reply To: Server Busy Message??

Derek Read

Reply to: Server Busy Message??

This message is thrown up by Windows when it detects that an application is not responding to COM requests. Given that this is likely being triggered by custom code it would be impossible to state why this is occurring exactly, only that whatever is being called is taking “too long” (or not responding at all). It would be best to check with your developers. They may be able to rewrite the script or application (possibly a DLL) that is involved (ideally so that it responds faster).

If they are unable to do so, it is possible (depending on what they are doing exactly) to increase the amount of time before such a message appears using the following XMetaL Author INI variable setting:

ole_server_busy_timeout =

The default value is 8 seconds:
ole_server_busy_timeout = 8000

This is only effective when a script is being run directly from within an XMetaL Author MCR file and that script is calling a COM object.

Note that if this is affecting XMAX there is no similar fix as XMAX does not currently support the equivalent of this INI variable setting.

Reply

Products
Downloads
Support