Pages: 1
Print
Author Topic: Uninstalled 6.0; re-installed 5.5 and now I can't generate any PDFs  (Read 2751 times)
carmstrong
Member

Posts: 11


« on: July 26, 2010, 02:36:33 PM »

I recently installed XMetaL 6, but after having issues with McAfee, I decided to go back to 5.5. Did a complete uninstall of 6, and then installed 5.5 with SP1. Previously, I had no issues with 5.5, but now when I try to generate output, XMetaL stops responding. Has anyone else experienced this issue? Thanks.
Logged
Derek Read
Program Manager (XMetaL)
Administrator
Member

Posts: 2621



WWW
« Reply #1 on: July 26, 2010, 03:05:35 PM »

The version of the DITA Open Toolkit that was deployed by XMetaL Author Enterprise 6.0 is probably still deployed and 5.5 will have trouble with it. The primary functionality of the DITA OT is basically the same in both versions (it is the DITA OT from SourceForce) but we do extend it (6.0 for example includes an updated version of our "Single HTML", the new "WebHelp", "XMetaL Enhanced PDF via RenderX" is improving over time, and possibly other things have been updated).

So, you will need to force 5.5 to deploy its own copy of the DITA OT.

The following will work with both  the 5.5 and 6.0 release:

1) With Author running, select Tools > Configure Output...
2) In the Configure Output dialog select the Advanced tab.
3) In the Advanced tab increase the value for the parameter called cmd_dita_ot_per_user_version by one or more. Example: cmd_dita_ot_per_user_version  =  2. If the parameter is not listed then add it (it should be there by default).
4) Click OK to dismiss the dialog.
5) Select Tools > Configure Output...
6) When prompted with the message to "upgrade" the DITA OT select the OK button.
7) The DITA OT should be redeployed and the Configure Output dialog will appear. You can then dismiss the dialog by pressing OK again.

Instead of step 5 you can also simply generate output. You will still be prompted to "upgrade" the DITA OT. That triggers the same redeployment.

For detailed information on why we "deploy" the DITA OT (and how to manage multiple installations in various different ways) please see this post:
http://forums.XMetaL.com/index.php/topic,237.0.html
Logged
carmstrong
Member

Posts: 11


« Reply #2 on: July 27, 2010, 08:53:43 AM »

Just completed these steps and this fixed my issue. Thanks!
Logged
Pages: 1
Print
Jump to: