Pages: 1
Print
Author Topic: Issues in PDF generated using XMetal 5.5  (Read 2896 times)
jittu.knl
Member

Posts: 2


« on: March 09, 2010, 12:38:52 AM »

Hi,
We are using XMetal Author 5.5 EE. We have a large documentation. After solving all memory problems, we successfully able to generate PDF from our documentation using XMetal 5.5. We found there are some issues in the generated PDF.

1. When scope='peer', the links are not working.
2. small icons are not coming As-Is. The icon color and look is changing. I tried to make them visible, by changing their back ground color etc in attributes. But I'm unalble to get the As-Is icon.
3.The links are not working for the topics, which are not in ToC.
4.How to get 'Before you begin' message with prereq tag.
5.How to get 'After you finish' message with postreq tag.

Please anybody reply to me with details. I mean, if any code I need to add, where to add the code, and what to add etc.

regards,
Jitendra
Cordys software
Logged
susannecm
Member

Posts: 1


« Reply #1 on: March 18, 2010, 05:55:22 PM »

Hi,

I can help you with one of your questions. To get labels in the task topic, you need to add something like this to a custom stylesheet, for example to [XMFO]\\Customization\fo\xsl\custom.xsl:

Code:
<xsl:template match="*[contains(@class, ' task/postreq ')]">
        <fo:block xsl:use-attribute-sets="section.title">
            <xsl:text>After you finish</xsl:text>
        </fo:block>
        <fo:block xsl:use-attribute-sets="postreq" id="{@id}">
            <xsl:apply-templates/>
        </fo:block>
</xsl:template>

HTH

Susanne
Logged
jittu.knl
Member

Posts: 2


« Reply #2 on: April 09, 2010, 05:42:21 AM »

Hi Susanne,

Thanks for the reply.
I did the changes to custom.xsl. It is working.

regards,
Jitendra
Logged
Pages: 1
Print
Jump to:  

email us