Pages: 1
Print
Author Topic: Xmetal 6.0 output issue  (Read 3274 times)
gcrews
Member

Posts: 265


« on: February 02, 2010, 02:10:42 PM »

I have a custom output type for generation that I can’t get XMetaL to say build was successful.
Xmetal 6.0 says output failed but the log says build successful. The output type from the toolkit generates files but the map is transformed into a filename based on the product attribute. As I recall Xmetal 5.5 used to say build completed but give you a dialog box just to open the output folder.
How do you get Xmetal 6.0 to say build completed successfully but if no destination file can be known beforehand? Or do I just need to have my custom output type just create a dummy file with the same input filename?

Thank you in advance
-geoff crews
Logged
james_uc
Member

Posts: 10


« Reply #1 on: March 23, 2010, 11:03:16 PM »

Hi Geoff

I haven't got an answer for you but I'm getting the same issue. My custom build makes a number of output files but there isn't one with the same name as the original map. I've not attempted to output a dummy file so far, but I don't really want to - the output files are web pages and I don't want to be generating any output that doesn't belong on the web server.

I'm also using XMetaL 6.0 with a new custom build, so I can't say what happens with earlier versions.
Logged
Derek Read
Program Manager (XMetaL)
Administrator
Member

Posts: 2621



WWW
« Reply #2 on: March 24, 2010, 02:44:44 PM »

Sounds like something we have not implemented an easy fix for yet but it does appear that our development team has been anticipating this need (I see signs of some feature that might address this but don't understand it exactly).

I'll have to check with one of our developers to see if there is a way to do this.
Logged
Derek Read
Program Manager (XMetaL)
Administrator
Member

Posts: 2621



WWW
« Reply #3 on: March 24, 2010, 05:54:32 PM »

In XMetaL Author Enterprise 6.0 we have a parameter you can add to the "other output parameter" settings on the Advanced tab for any deliverable type and this will tell the generation process to not check for the presence of a particular output file having been created. Basically what you are asking for I think (with one very minor problem).

Do the following:
1. Tools > Configure Output, and in the list of deliverable types select yours and click Edit.
2. In the dialog that appears, on the Advanced tab inside the text box labeled "Other output parameters" add the following new param on a new line: cmd_output_as_dir  =  yes.
3. Click OK then OK again to get back to the main document editing view (which also saves that change).

Now when you generate output using that deliverable type the generate output process will not bother to check to see if a specific file was created.

The catch eluded to above is that both the "Open File" and "Open Folder" buttons are still displayed. Clicking either of them opens the folder in this case, so not really a big deal but possibly a little confusing for authors. I consider this a bug though and have asked dev to look into hiding the button in this case in a future release.
Logged
Pages: 1
Print
Jump to: