Pages: 1
Print
Author Topic: XMetaL 12 Crashes  (Read 336 times)
megl
Member

Posts: 6


« on: May 29, 2019, 07:27:54 AM »

I have a user on Windows 10 Pro using XMetaL 12 Enterprise who is having crashing issues. Whenever text is highlighted, even just a few words, XMetaL crashes.

Any insight to a workaround or settings adjustment to resolve this would be helpful.

Thanks,
Meg
Logged
Derek Read
Program Manager (XMetaL)
Administrator
Member

Posts: 2621



WWW
« Reply #1 on: May 29, 2019, 04:03:49 PM »

It sounds like this is limited to one user, so identifying what is different about this particular computer's setup would be the first step. Compare any files installed that modify or extend the XMetaL Author installation: "application customization" files (this would include CMS integration modifications or other changes to the software, primarily limited to scripting modifications or other code that is calling XMetaL APIs) as well as "document customization" files (the DTD/XSD plus any other files loaded when a particular XML file is loaded, which can include script inside MCR, CTM and possibly other files). The people that created these customizations should be able to do this.

If this is affecting multiple users then debugging can be done by the people that created any custom scripts or other code you are running then the code to examine in particular would be anything inside events corresponding to mouse clicks (On_Click, On_Double_Click), the "Selection" object in general (or the mostly equivalent "Range" object), events that fire frequently (On_Update_UI), or similar.

If that isn't possible for whatever reason please feel free to submit any customizations plus a sample XML document to XMetaL Support so they can try to reproduce the issue. If the issue is limited to one person then the most likely cause is a broken file. If the issue is affecting everyone, but has not in the past, then it is most likely that changes to the customization have been made that are buggy that were not properly tested, or that an API is being used incorrectly, or if used correctly then perhaps in an unexpected way that was unforeseen.

The more information that can be provided to XMetaL Support the better as they will likely need to reproduce your setup as closely as possible to trigger the issue.
Logged
Pages: 1
Print
Jump to:  

email us