Pages: 1
Print
Author Topic: topic with schema reference gives "Path not found" (Solved)  (Read 153 times)
KdG
Member

Posts: 19


WWW
« on: November 09, 2018, 10:20:51 AM »

[This issue has been solved, and appeared to have nothing to do with schema-reference. (see last message)]

We have a serious issue that occurs since XMetaL Author 13.0 x86 (Binary#: 13.0.0.038 Installer#: 13.0.0238)

When you open a file that holds a schema reference, XmetaL gives an unnecessary message "Path not found"
After the message the file opens correctly, and can be validated correctely against the schema.

Steps to reproduce:
1. Create an XML file with a schema reference like:
<topic xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" class="- topic/topic " xsi:noNamespaceSchemaLocation="c:\temp\schema\topic.xsd">

2. Place the schema in the correct location.
3. Open the file in XMetaL.

Where does this message come from, and how can it be avoided?

« Last Edit: November 12, 2018, 02:58:05 AM by KdG » Logged
Derek Read
Program Manager (XMetaL)
Administrator
Member

Posts: 2580



WWW
« Reply #1 on: November 09, 2018, 06:17:09 PM »

Is this issue reproducible with the Journalist sample for you?
I can't seem to reproduce it, or I misunderstand the issue.

1. Select: File > New > Journalist (tab) > SchemaArticle (template)
2. No errors.

I would recommend sending a sample of any files needed to reproduce this issue to XMetaL Support so they can test with the same setup you have.
Logged
XMetaLOldTimer
Global Moderator
Member

Posts: 54


« Reply #2 on: November 09, 2018, 06:29:18 PM »

Are your trying use the DITA XML schemas?  If so, you need to have DITA Options set to version 1.3.  And our out-of-the-box catalogs for DITA XML schemas are setup to match the OASIS DITA URNs such as this example below:


<topic xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
 xsi:noNamespaceSchemaLocation="urn:oasis:names:tc:dita:xsd:topic.xsd"
 xmlns:ditaarch="http://dita.oasis-open.org/architecture/2005/"
 id="topic_A9A9B50EA68A4FFA960272F6F65B7E16">


Regards,
Addam
Logged

Addam Smith, XMetaL Project Lead & Architect
JustSystems Canada Inc.
KdG
Member

Posts: 19


WWW
« Reply #3 on: November 12, 2018, 02:55:12 AM »

Thank you for your prompt response.

I soved the issue. It is completely my mistake.
Last week it took me several hours to drill it down to the schema-reference, but it is not that!

! Sorry for bothering you unnecessarily.


(FYI: It had to do with a macro writing the "topic_HTML_Custom.xsl" to the roaming\softquad\..\display folder.)
Logged
Pages: 1
Print
Jump to:  

email us