Pages: 1
Print
Author Topic: XMetaL 12 - Windows 10 - Default Application Problem  (Read 74 times)
rshubert
Member

Posts: 3


« on: October 12, 2018, 04:52:01 PM »

I recently upgraded to Windows 10.
XMetaL 12 is no longer set as my default XML application.
How can I set XMetaL 12 as my default application for XML files?

I've tried right clicking a .XML file and choosing XMetaL as the "always use this application" button and it didn't stick.
I've tried using the file extension assocation too and it did not stick.
The system seems to default to "Office Handler" for opening XML files. Any tips would be appreciated.

Thanks in advance.
Logged
Derek Read
Program Manager (XMetaL)
Administrator
Member

Posts: 2575



WWW
« Reply #1 on: October 12, 2018, 06:41:02 PM »

In my case doing what you've stated here works for any application and file type on my machine (Windows 10 Enterprise), including associating .xml files with Notepad, XMetaL Author, then back to the default (which in my case was originally set to IE), then back to XMetaL Author.

However, I see in various places people are saying they have used Windows 10's "Choose default app for filetype" to do this instead. Search for that in Settings.

I don't think the Windows Registry area that stores file associations has changed (the keys for each filetype are listed under \HKEY_CLASSES_ROOT\ by file extension, so for XML it's under \HKEY_CLASSES_ROOT\.xml) so it's a mystery to me why one way to set this through the Windows GUI would work and the other doesn't.

Maybe Office has some additional feature configured that grabs that file extension back if you change it? I recall an issue like that with some specific version of IE (around when XP was the main version of Windows people used) and in the past some other XML authoring tools also had a setting that would check at startup to see if XML files were associated with them and reset it if it wasn't.
Logged
Derek Read
Program Manager (XMetaL)
Administrator
Member

Posts: 2575



WWW
« Reply #2 on: October 12, 2018, 07:01:30 PM »

Discussion of how Microsoft has changed the way file associations work in Windows 10:

https://blogs.windows.com/windowsexperience/2015/05/20/announcing-windows-10-insider-preview-build-10122-for-pcs/

I suspect your version of Office is using the new way, which seems to take precedence over the old way of doing file associations. So, with Windows 10 there are actually two ways to associate file types. If you set it the old way (as you were trying) that will work for old applications, but only if you don't have a new "app" installed. In that case you need to set it the new way since the new way is apparently checked first and only if there is no association there does it look for the old file association method.

The post above explains why. Seems to me that they could have come up with a better solution, but that's how it is.
Logged
rshubert
Member

Posts: 3


« Reply #3 on: October 15, 2018, 01:12:48 PM »

Ok, still a bit per-plexed with the file-association changes.
I did manage to get XMetaL to be the default application by going to .XML instance in the registry and setting the value to "ditafile". XMetaL had been the default application for dita files and dita maps, just not xmetal. So far this seems to work, so I'm sticking with it.

Logged
Pages: 1
Print
Jump to: