Pages: 1
Print
Author Topic: XMetal stopped responding and Crashed  (Read 887 times)
rakesh
Member

Posts: 3


« on: November 11, 2016, 03:50:55 AM »

Hi,

I have encounter a mysterious problem. When I am trying to open a xml file, XMetal stopped responding. When I disconnect the internet then XMetal open the xml file successfully. Any suggestion ?

Thanks
Rakesh 
Logged
Derek Read
Program Manager (XMetaL)
Administrator
Member

Posts: 2502



WWW
« Reply #1 on: November 14, 2016, 02:20:52 PM »

Couldn't tell you without seeing the XML file and the customization files that are loaded when it is being loaded. Possibilities:

1) The XML file itself references something on the internet (a reference to an image or other file) and it is waiting for that to download so it can be displayed and dealt with.
2) The DTD or XSD that the XML file references is on the internet, or a portion of it is on the internet, and similar issues to #1 are occurring.
3) A macro or script inside an MCR, CTM, XFT or ActiveX control associated with the XML file (as part of the customization) is being loaded and it has code that is taking a long time to complete. The fact that this occurs only when you have an internet connection suggests that the script is doing something over the internet.
Logged
rakesh
Member

Posts: 3


« Reply #2 on: February 21, 2017, 02:04:17 AM »

Many thanks for your reply, Yes you are correct we have online dtd reference in our xml document. We have corrected the reference and now it is working fine.
Logged
Pages: 1
Print
Jump to: