Pages: 1
Print
Author Topic: XMetaL Author Essential 10 Crash  (Read 479 times)
megl
Member

Posts: 3


« on: November 09, 2016, 03:41:44 PM »

I have users with XMetaL Author Essential 10 that crashes every time it is opened, whether from the Start menu or from our Repository. Using Windows 7 operating system.

I have had them try uninstall (including removal of softquad folders and registry keys) and re-install, open XMetaL with Ctrl key, Repair install, change the xmetal.ini file user_setting_mode=default. Nothing seems to keep XMetaL from crashing.

Any suggestions would be appreciated.

Logged
Derek Read
Program Manager (XMetaL)
Administrator
Member

Posts: 2463



WWW
« Reply #1 on: November 10, 2016, 01:37:13 PM »

I'm assuming you made a mistake when you stated that you are using XMetaL Author Essential? It sounds like you have a repository connector installed? If so, that usually requires XMetaL Author Enterprise (at least if the connector was written according to our recommendations).

When XMetaL Author Enterprise (or Essential) is crashing like this there are two main reasons for it:

1) The customization files associated with a particular XML document are causing the crash. The most likely cause for that is a script. This would be inside an MCR file or a file an MCR file loads, a CTM file, or an XFT file. The issue might also be in an ActiveX control (usually a DLL) embedded into the document's display area or inside an XFT. Resetting the workspace (which you have done by holding the Ctrl key down and answering "yes" when prompted to reset the workspace) eliminates this possibility by restoring XMetaL Author to its default state, including not loading any previously opened XML files. So I don't think this is the issue.

2) An application-level script loaded at startup is triggering the crash. To resolve this you will need to remove all custom MCR files from the Startup and Macros subfolders in the installation, including any added by your repository vendor. A clean installation of the software will do this provided you only run our installer. Once you can identify any custom files that might be the cause the creator would need to test and debug them.

If the repository connector must be installed to reproduce the issue then you will need to have the vendor that supplied the connector test it using the same setup you have and have them resolve it. If they are unable to resolve the issue they can then work with the XMetaL development team.
Logged
Pages: 1
Print
Jump to: